1

I've upgraded Ubuntu 20.04 to 20.10. Unfortunately when I try to start xen with these commands :

sudo /etc/init.d/xencommons start
sudo /etc/init.d/xendomains start
sudo /etc/init.d/xen-watchdog start
sudo /etc/init.d/xendriverdomain start

I get this error :

Starting /usr/local/sbin/oxenstored...Setting domain 0 name, domid and JSON config...
Done setting up Dom0
Starting xenconsoled...
Starting QEMU as disk backend for dom0
/usr/local/lib/xen/bin/qemu-system-i386: error while loading shared libraries: libnettle.so.7: cannot open shared object file: No such file or directory
* [done]
Starting xen-watchdog (via systemctl): xen-watchdog.service.

It didn't happen with Ubuntu 20.04, so 20.10 removed some "obsolete" package. I tried to reinstall some packages related to nettle component, but the error didn't go away. Somone wants to help me? Thanks.

0

You have to install the package by

sudo apt-get install libnettle7:i386

or manually by

cd ~/Downloads
wget http://archive.ubuntu.com/ubuntu/pool/main/n/nettle/libnettle7_3.5.1+really3.5.1-2_i386.deb
sudo apt-get install ./libnettle7_3.5.1+really3.5.1-2_i386.deb
3
  • done. the error is still there,intact. – Marietto Oct 24 '20 at 13:59
  • maybe this is the right file ? ---> ftp.br.debian.org/debian/pool/main/n/nettle/libnettle7_3.5.1+really3.5.1-2_amd64.deb – Marietto Oct 24 '20 at 14:02
  • no. it isn't : Estrazione di libnettle7:amd64 (3.5.1+really3.5.1-2)... dpkg: errore nell'elaborare l'archivio /etc/xen/libnettle7_3.5.1+really3.5.1-2_amd64.deb (--unpack): tentata sovrascrittura di "/usr/share/doc/libnettle7/changelog.Debian.gz" (condiviso), diverso da altre istanze del pacchetto libnettle7:amd64 dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta) – Marietto Oct 24 '20 at 14:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.