7

I've just updated to Firefox 82 on my Ubuntu 20.04 machine. Immediately it's apparent that the tab bar has been merged into the window title bar. I'm all for saving screen real estate, but as far as I can tell, this change means that the context menu for windows is no longer available. In particular, Move to workspace down I use a lot.

Right-clicking on the title bar only produces the Firefox tab bar context menu, not the window context menu:

enter image description here

Is there a setting that controls this behaviour, or a way to get the window context menu that I haven't been able to find yet?

  • Try pressing Alt, this should show the window menu bar – stackzebra Oct 24 at 19:23
  • 1
    Not an answer to your question, but: "In particular, Move to workspace down I use a lot." - Consider assigning a keyboard shortcut (Settings > Devices > Keyboard, I think?) to any actions you use a lot. That can really help speed things up :) – marcelm Oct 24 at 19:45
  • 1
    @stackzebra <kbd>Alt</kbd> shows the File/Edit/View menu bar only, which doesn't get you access to the window controls. Posts below show how to enable the title bar again. – Kyle Gilbertson Oct 27 at 16:24
7

Firefox uses legacy window decoration, i.e., the classical title bar, which is provided by the window manager. The title bar can be shown or hidden through the Firefox preferences dialog. If you hide it, you loose that right-click window context menu, unfortunately.

To directly have the context menu for windows available, your only option is to enable the title bar. Alternatively, you can still show it using the shortcut key Alt+Space. A shortcut key to directly move a window down is Super+Shift+Arrows. However, this will not send the window away, but take you along with the window to the next workspace.

| improve this answer | |
13

If you go into Customize, you can enable the title bar again. It's a checkbox in the lower left corner on the Customize dialogue.

| improve this answer | |
  • Good catch!! I was missing the title bar for a while – ram0nvaldez Nov 20 at 21:26
0

Same on Ubuntu 18.04. I found a solution: Right click wherever up there, to get the Firefox tab bar context menu (the one with "Menu Bar", "Bookmarks Toolbar", and "Customise" in it. Click Customise. Check "Title Bar" at the bottom of that Customise screen. That's it, everything shifts down 1 "row" and is out of the window border. (Note the menu bar is greyed out when in Customise.. I was alarmed when I noticed this and thought it broke when I moved it out of the window title. Nope, it's fine, it un-disables as soon as you close the Customise tab.)

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.