24

Any tips?

  • Intel Core 2 Quad x64
  • Ubuntu precise 12.04
  • Dell OptiPlex 760
  • nvidia graphics driver
3
  • Same problem here... Dell Precision, dual core, NVidia graphics card.
    – Matthieu
    Commented May 17, 2012 at 18:37
  • 1
    @JosuhaRountree I know what you mean. I think you should give Ubuntu another chance. Just don't use anything above 11.04. Get 9.10 or something and if you want to use 11.04 or 11.10 make sure that you get gnome-panel which is the closest thing to gnome 2 and significantly reduces the grief of compiz. I use Ubuntu 11.10 with gnome-panel. I am a mathematical programmer and with this config I end up using only 500MB which is 1/16th of my RAM.
    – dearN
    Commented Oct 28, 2012 at 13:57
  • Why didn't you just use another distro?
    – JMCF125
    Commented Sep 11, 2013 at 13:38

4 Answers 4

30

I also had compiz constantly taking around 10-12% CPU. I installed ccsm using

sudo apt-get install compizconfig-settings-manager

launched CCSM and under the OpenGL unticked sync to vblank. Now compiz is only taking up 2-4% CPU.

This website also suggests setting Texture Filter to fast.

7
  • 1
    works fine for me with an ati 7950
    – unludo
    Commented Mar 21, 2013 at 17:41
  • 2
    Any idea why this works?
    – Alex
    Commented Jun 24, 2014 at 7:18
  • Also documented here which additionally suggests to change the "Texture Filter" from "Good" to "Fast". Commented Jun 23, 2015 at 6:19
  • Worked for me too!
    – Amorphous
    Commented Aug 19, 2015 at 15:04
  • 1
    Link is broken.
    – DavidJ
    Commented Nov 2, 2017 at 20:58
6

Had the same problem. Compiz constantly at around 40% (AMD CPU, ATI 58xx, 12.04). Then i followed the instructions in this answer and CPU utilization dropped below 10%. Hope it helps.

1

For me in 12.10, removing the compiz settings on ~/.compiz and rebooting solved the problem. I just renamed the folder, it might help if you want to recover your settings after all.

0

What seems to help with Ubuntu 12.04 x64 on a T61 with NVIDIA GPU was unticking sync to VBlank in ccsm OpenGL settings. Sync to vblank is already enabled in nvidia-settings so there's no vertical tearing or such.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .