3

I upgraded to Ubuntu 20.10 recently and the first thing I noticed after rebooting my computer was that my application menu got flooded with many applications, all of them referring to some terms used in audio(like this) and when I open them I get some sort of audio console with their window titles in German language and the active window name on the top left being lsp-plugins

Following are the kind of windows I get when I open these apps: one when I tried booting from the old kernel(5.4.0-52--generic) and another app of the same sort when I'm on the newer kernel(5.8.0-25-generic).

I tried:

sudo apt install --reinstall lsp-plugins

sudo apt remove lsp-plugins ; sudo apt autoremove ; sudo apt install lsp-plugins

and nothing changed on the app menu, these apps even started fine with no errors even after I did sudo apt remove lsp-plugins ; sudo apt autoremove.

When the apps are opened through the terminal using lsp-plugins-nameofprogram the output is as follows

Cannot connect to server socket err = No such file or directory
Cannot connect to server request channel
jack server is not running or cannot be started
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
JackShmReadWritePtr::~JackShmReadWritePtr - Init not done for -1, skipping unlock
[WRN] Could not connect to JACK (status=0x00000011)

this seems to indicate there's no audio jack connected to my laptop, but I only use a Bluetooth device and I've never plugged an audio jack into my Laptop. Judging from the autocomplete feature in the terminal there seems to be 118 apps of this sort.

3 Answers 3

12

I've found an answer for this from a Reddit post in the r/linux4noobs subreddit. The solution is in the comments and is posted by u/mthqwork. I'll paste the command that I used here. First do

echo "[Desktop Entry] Hidden=true" > /tmp/1

then do

find /usr -name "*lsp_plug*desktop" 2>/dev/null | cut -f 5 -d '/' | xargs -I {} cp /tmp/1 ~/.local/share/applications/{}

The applications will now get hidden which is why I didn't see them in my previous Ubuntu version (20.04).

3
  • 1
    This issue is caused because GNOME hasn't conformed to XDG standards and has developed it's own mechanism for publishing desktop applications. Normally these apps are grouped into a single folder on other DE's. Ubuntu has worked-around this by hiding them in the application manager but it didn't happen when I upgraded to 20.10 with the newer packages and that was the reason for this. I've learnt what caused the problem from the same Reddit post from the comment of user r/sadko4u. His account is suspended and I'm not sure if this is the right reason so I'm leaving this in the comments.
    – user1131566
    Oct 24, 2020 at 8:01
  • Nice! Solved the problem on Pop OS 20.10
    – Matt West
    Dec 3, 2020 at 21:35
  • The same problem is happening to me in Ubuntu 21.04, but unfortunately this solution doesn't seem to work for it. :( Jul 7, 2021 at 8:01
0

The best (and I think only safe) way to fix this is to bring up the Menu Editor by typing "edit" after clicking on the menu/start button.

Navigate to "LSP Plugins" and choose to not have it show from the menu.

*You can also choose to have the CALF plugin thingie to not show if you have that but don't use it. Cheers!

1
  • this does not apply the hide setting to all the individual entries. Jan 16, 2021 at 11:11
0

I had the same problem in Debian Bullseye. I got the package together with PulseEffects equalizer.

After trying the above answers without results, I tried to find details in Debian. The package seems to be called lsp-plugins-vst, but I couldn't remove it (it appeared as not installed). I then tried:

sudo apt purge lsp-plugin*

This command found a few packages to remove and I got rid of the plugins. Success!

You must log in to answer this question.