1

I am used to ctrl-alt-Fn (say, ctrl-alt-F3) to get a terminal CLI console scrolling screen. On 20.04 LTS (MATE Xwindow environment), the default ctrl-alt-F1 is the (dark pink) login screen, ctrl-alt-F2 is the Xwindow MATE screen, but the rest do not produce a login prompt but merely a dark "blank" screen. How does one enable these other consoles with a login CLI (e.g., bash)? Neither a web search engine search nor a Search on Ask Ubuntu has found the answer, possibly because I am not using the currently correct search target words. Take care. Stay safe.

1 Answer 1

1

The answer is in Enable Ctrl+Alt+F1 Virtual Consoles in GNOME (Ubuntu 17.04+)

The solution of modify /etc/systemd/logind.conf, uncomment NAutoVTs=6 and restart.

Also, check /etc/default/console-setup, the line: ACTIVE_CONSOLES="/dev/tty[1-6]"

works on 20.04 LTS, but a reboot is required -- a systemctl as further in the answer I found locks the GUI Xwindow screen, requiring a reboot, at least when I just tried it as root.

1
  • I also have Ubuntu 20.04, but the F1 and F2 consoles aren't made accessible with this, the first is an extra DM log in screen, and the second the graphical session opened by default. F7 is a blinking cursor. F3-6 do work as expected however.
    – Joce
    Oct 16, 2023 at 10:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .