0

My Elantech Touchpad on a Lenovo P73 system is delayed every time I press a key, and the delay is significant. This problem didn't occur in Ubuntu 18.04, and I didn't find where the touchpad delay could be configured in 20.04. Is there any way around this in 20.04?

2 Answers 2

0

Have you installed the gnome tweaks tool?

$ sudo apt install gnome-tweak-tool

This offers more options when dealing with all mouse and touchpad related issues.

I have a Thinkpad T480, but I use the trackpoint, which is recognized by the system as a mouse instead of the touchpad. I just keep the touchpad disabled and haven't used it at all.

If you have that option, I would recommend doing that. Otherwise, I have seen other issues surrounding the P series and Ubuntu.

This thread may be of some assistance to you. https://bugs.launchpad.net/ubuntu/+source/xorg-server/+bug/1868474

1
  • 1
    For touchpad, the Tweak tool only offers to automatically disable it while typing, I have this option on, but there is no delay time control setting there. In 18.04 the delay was much smaller and/or it was controllable. It is strange why they did it this way in 20.04, looks like there are fewer touchpad controls for it. Also, in 20.04 there is no option of "inertia" scroll, i.e. when you swipe with two fingers up or down quickly and the window moves its content up or down with decreasing speed. For the trackpoint, I didn't find it to be as convenient.
    – sequence
    Commented Oct 22, 2020 at 19:53
0

I found that setting tap-and-drag to false fixed it for me:

gsettings set org.gnome.desktop.peripherals.touchpad tap-and-drag false

After that, touchpad taps suddenly became instant.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .