1

I have esxi 7 installed and I have passed through my Nvidia RTX 2080 ti to the guest. On the guest side, I have installed ubuntu desktop 20.04 with Plasma and Wayland with the support for Nvidia,following this tutorial :

https://community.kde.org/Plasma/Wayland/Nvidia

lspci shows me that the nvidia graphic card has been detected and passed through and it is using a manually installed driver.

enter image description here

enter image description here

enter image description here

Infact I have installed at first the ubuntu nvidia driver,later the proprietary driver. However,if I want to render a scene with blender using the 2080 ti I can't do it because it said that it can't find a compatible gpu for path tracing.

enter image description here

Also,ubuntu detects only one monitor,the monitor attached to the esxi default virtual graphic card (that I'm not able to disable,infact on the monitor panel I see that it is enabled only the vmware virtual monitor),but the rtx 2080 is attached to another monitor,that it is not detected.

enter image description here

but on the driver panel it says that the VMware vga adapter is not working). The same happens with Gnome with wayland enabled. I have passed through also the Intel graphic card and this time it works. I can see the external monitor activated and that it is using that card as primary. I suspect that the nvidia driver does not like wayland for some reason. What do u think ? But esxi likes it,infact when I pass the intel internal card I can activate the external monitor only if I enable Wayland. Is there a way to force the nvidia driver to work great with wayland ? thanks.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.