I'm a student who uses the laptop all the time and I have a problem with Wifi on the laptop. I don't really know what it is. I can describe the problem tho. For example, i closed my laptop last night, so it goes in suspend mode. I turn it on this morning and my wifi doesn't want to connect until I restart the laptop. It says that it's connecting and in Wifi settings the circle animation is spinning, turning Wifi off and on doesn't do anything. Here's what happens when I check to see my network info:

sudo lshw -C network
       description: Wireless interface
       product: Wireless 3160
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: wlp2s0
       version: 83
       serial: 00:1e:64:e6:1c:93
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress bus_master cap_list ethernet physical wireless
       configuration: broadcast=yes driver=iwlwifi driverversion=5.4.0-52-generic firmware=17.3216344376.0 ip= latency=0 link=yes multicast=yes wireless=IEEE 802.11
       resources: irq:129 memory:df100000-df101fff
       description: Ethernet interface
       product: RTL810xE PCI Express Fast Ethernet controller
       vendor: Realtek Semiconductor Co., Ltd.
       physical id: 0
       bus info: pci@0000:03:00.0
       logical name: enp3s0
       version: 07
       serial: f8:ca:b8:52:72:49
       capacity: 100Mbit/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix vpd bus_master cap_list ethernet physical tp mii 10bt 10bt-fd 100bt 100bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=r8169 firmware=rtl8106e-1_0.0.1 06/29/12 latency=0 link=no multicast=yes port=MII
       resources: irq:17 ioport:d000(size=256) memory:df000000-df000fff memory:d0000000-d0003fff

Also I have to mention that my Linux is doublebooted alongside Windows 10, but I don't think that makes any difference. Help would be much appreciated, I wouldn't want to miss my classes because of this hahah Thanks!


Disable Windows Fast Startup feature.

Windows 10 doesn't shut down properly but hibernates.

This may cause some trouble with wireless devices if you boot to Ubuntu and also NTFS partitions are mounted read-only.

| improve this answer | |
  • this? imgur.com/a/7WdUtuB – Harun Subasic Oct 21 at 9:04
  • Yes, that one.. – Pilot6 Oct 21 at 9:06
  • Seems to be working well. I will report tomorrow if the error occurs again or not. Thanks – Harun Subasic Oct 21 at 14:27
  • Looks like it's working well.. Thank you! – Harun Subasic Oct 23 at 18:25
  • Update: This morning I restarted just to check if it works well still, and the problem is still the same, connecting all the time but never connects. Help? – Harun Subasic Oct 24 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.