0

I have installed Vsftpd Server listening on port 21 in ubuntu server. I've forwarded a port in my router to forward external port 8500 to internal port 21 where my vsftpd server is listening on. However, when I try to connect using ftp client, I'm seeing the following message in filezilla,

"Server sent passive reply with unroutable address. Using server address instead"

I've read that this has to do with being behind a router. But I never had any issues with other routers. Any reason why I am able to access ftp from the outside when using one router but not the other?

1

FTP protocol is specific, as it uses two simultaneous connections, in opposite to other protocols like SSH, HTTP or SMTP that use only one.

Therefore a NAT code on the router needs some special handling of the second connection in case of the FTP protocol - it cannot be handled just like a generic other protocol. Most routers have this functionality (and you don't have a problem with FTP on them), but some don't (and in that case you have a problem).

There is an option, pasv_address, in VSFtpd config file that you can use to tell VSFtpd to present a specific IP address on that second connection, so using this you can work around this router bug.

1
  • This clears up my question. I guess I will use sftp instead since after all, I do have openssh server installed as well. Thanks. – Malanie Oct 21 '20 at 2:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.