10

Calibre stopped working recently. Tried uninstalling and reinstalling.

When I open a terminal and call $calibre I get the following error message:

Traceback (most recent call last):
  File "/usr/bin/calibre", line 20, in <module>
    sys.exit(calibre())
  File "/usr/lib/calibre/calibre/gui_launch.py", line 73, in calibre
    main(args)
  File "/usr/lib/calibre/calibre/gui2/main.py", line 543, in main
    listener = create_listener()
  File "/usr/lib/calibre/calibre/gui2/main.py", line 514, in create_listener
    return Listener(address=gui_socket_address())
  File "/usr/lib/calibre/calibre/utils/ipc/server.py", line 110, in __init__
    self._listener._unlink.cancel()
AttributeError: 'NoneType' object has no attribute 'cancel'

Do I need to install some dependency that the sudo apt install didn't get? I tried installing via command line and the software installer/updater GUI.

I'm on version Ubuntu 20.04.1 LTS. I made sure that my software in general is up to date also.

  • 3
    From what I can see, Calibre 4.99 and under (which is what is in the 20.04 repos) was written for Python 2 and not Python 3. Calibre released version 5 for Python 3 which I wish was in the repos, but you can install it from calibre-ebook.com/download_linux 20.04 no longer has Python 2. – Terrance Oct 20 at 18:53
  • @Terrance that did it thanks. Please make it an answer so I can mark it accordingly – rory Oct 20 at 18:59
  • installing the newer version (now it was 5.5) from the suggested link has worked like a charm – Quaesitor Veritatem Nov 20 at 19:47
15

Unfortunately, at this moment the version of Calibre that is in the 20.04 repos is version 4.99 which does not work with Python 3. Since Python 2 is EOL it is no longer installed by default into Ubuntu 20.04.

Calibre has released version 5.3.0 that works with Python 3. You can download it from https://calibre-ebook.com/download_linux

Or you can run the command from that site to install it

sudo -v && wget -nv -O- https://download.calibre-ebook.com/linux-installer.sh | sudo sh /dev/stdin

Hope this helps!

| improve this answer | |
0

https://download.calibre-ebook.com/4.html

Go to this site and download previous version. extract the file run the Calibre file (which as no extension) just double click.

| improve this answer | |
0

Sorry for interupting, This may not be an ideal go around, but maybe a temporary solution. I also face the same problem, in my Ubuntu 20.04, and I decided to install the flathub version instead and its being running fine up till now.

https://flathub.org/apps/details/com.calibre_ebook.calibre

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.