2

I have a HP 2540 printer that worked correctly in 18.04 but not in 20.04.

I tried to install HPLIP from Hp (version 3.20.9) but got the next warnings and errors:

warning: Missing REQUIRED dependency: pyqt5 (PyQt 5- Qt interface for Python (for Qt version 4.x))
warning: Missing OPTIONAL dependency for option 'gui_qt5': pyqt5-dbus (PyQt 5 DBus - DBus Support for PyQt5)
warning: Missing OPTIONAL dependency for option 'gui_qt5': python-notify (Python libnotify - Python bindings for the libnotify Desktop notifications)
warning: Missing OPTIONAL dependency for option 'fax': reportlab (Reportlab - PDF library for Python)
warning: Missing OPTIONAL dependency for option 'scan': pil (PIL - Python Imaging Library (required for commandline scanning with hp-scan))
warning: This installer cannot install 'pil' for your distro/OS and/or version.

error: Package install command failed with error code 100

Then I uninstall HPLIP, as this answer suggest How to install latest HPLIP on my Ubuntu to support my HP printer and/or scanner? and install hp-plugin without success. The printer is added but it appears as busy or "Device communication error"

Also the scan doesn't work.

I don't know how to process now.

4
  • I woud guess that you are far more interested in being able to print and scan than in debugging HPLIP 3.20.9. So please connect the 2540 by wireless and give the output of driverless.
    – brian_p
    Oct 22 '20 at 11:11
  • You can only connect the 2540 series printer in a WEP wireless network so it isn't feasible. Thanks! Oct 22 '20 at 16:29
  • WEP only? That isn't what the manual for the Deskjet 2540 says!
    – brian_p
    Oct 22 '20 at 17:10
  • @brian_p thanks for the heads up on using it wireless mode, I was able to get an HP Deskjet 2652 working on ubuntu 20.04 with your suggestion. ( askubuntu.com/a/1309755/193850 ) something to do with USB and IPP not playing so nicely together, or so it seemed. have no idea what the issue was.
    – jmunsch
    Jan 21 at 7:55
2

Found this solution on ubuntuusers.de:

    apt show ippusbxd
    Package: ippusbxd
    Version: 1.34-2ubuntu1
    Priority: extra
    Section: comm
    Origin: Ubuntu
    Maintainer: Ubuntu Developers <ubuntu-devel-discuss@lists.ubuntu.com>
    Original-Maintainer: Debian Printing Team <debian-                                                                        printing@lists.debian.org>
    Bugs: https://bugs.launchpad.net/ubuntu/+filebug
    Installed-Size: 110 kB
    Provides: cups-filters-ippusbxd
    Depends: libavahi-client3 (>= 0.6.16), libavahi-common3 (>= 0.6.16), libc6  (>= 2.15), libcups2 (>= 1.7.0), libusb-1.0-0 (>= 2:1.0.16), libxml2 (>= 2.7.4)
    Recommends: system-config-printer-udev
    Conflicts: cups-filters-ippusbxd
    Replaces: cups-filters-ippusbxd
    Enhances: cups
    Homepage: https://github.com/OpenPrinting/ippusbxd
    Task: ubuntu-desktop-minimal, ubuntu-desktop, kubuntu-desktop, kubuntu- full, xubuntu-desktop, lubuntu-desktop, ubuntustudio-desktop, ubuntukylin-desktop,  ubuntu-mate-core, ubuntu-mate-desktop, ubuntu-budgie-desktop
    Download-Size: 36,0 kB
    APT-Sources: http://archive.ubuntu.com/ubuntu focal/main amd64 Packages
    Description: Daemon for IPP USB printer support
    ippusbxd is a userland driver for USB devices supporting the IPP USB
    specification. It enables these USB printers to be seen as regular
    network IPP printers.

Seems that

    sudo apt purge ippusbxd

fixes the problem.

1

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.