0

my system is set up like this:

  • GIGABYTE AORUS GAMING 5 Z370 mobo

  • GTX 1660 Ti connected to 4K monitor

  • 250GB NVMe: Windows 10

  • 500GB NVMe: NTFS

  • 120GB SSD: empty

  • 120GB SSD: might be dead? should have ubuntu 20.04 installed on it, can't see it in BIOS or windows disk management

  • 275GB SSD: empty

I have been trying to install ubuntu 20.04 from a USB drive (set up with RUFUS) to either of the empty SSDs, and having a hell of a time.

Originally, the issue appeared to be that (after selecting the USB drive for boot and arriving at the USB's grub2 menu) If I selected "Install Ubuntu", I would get kicked to a screen showing my mobo's logo, a "disk checking" progress bar, and a "ubuntu" wordmark at the bottom. Once the disk check finished, the progress bar disappears, and nothing further seems to happen -- I've left it like this overnight and nothing changes.

Next, I found that I could progress past the disk check freeze If I selected "Install Ubuntu (safe graphics)", and I would boot into the USB's OS and be able to install ubuntu. however, the installer would always crash when attempting to install third-party software, so I disabled that option and continued through a successful install.

However, now I cannot boot into my ubuntu installation at all. If I select the ubuntu drive from BIOS boot menu, The screen turns black immediately, everything freezes, and eventually my monitor goes to sleep.

I've tried:

  • installing on both of the SSDs, with similar results
  • creating the live USB stick on different computers with fresh .iso downloads
  • BIOS update + complete BIOS reset
  • Turning CSM support on and off in BIOS
  • CSM=OFF allows me to access secure boot settings, where I always set secure boot to OFF. With these settings set, I am able to reach the GRUB2 screen when booting into my ubuntu drive, but immediately I get the AE_NOT_FOUND error. Here's a link to a picture of the error -- you can also notice some graphical glitching.
  • CSM=ON: Black screen/freezing as described before

Could this be because of my graphics card? Do I need to somehow update the ubuntu nvidia drivers before ubuntu crashes?

Thanks in advance for looking at my problem!


UPDATE: I tried booting with CSM=ON, but this time I got into the TTY terminal using Ctrl+Alt+F2 (I kept pressing those buttons repeatedly after the initial BIOS screen disappeared). I was able to log in through this terminal. I then installed an Nvidia driver for my card using this command:

sudo apt-get install nvidia-driver-450

(As of the time of this question's posting, 450 is a relatively recent driver for my card)

I rebooted, and then I was able to get into ubuntu! so problem solved.. I guess? The only problem is that there's no GRUB menu at boot for me to switch between ubuntu and windows 10, so I guess this is my next issue to figure out...

0

The AE_NOT_FOUND error is relatively easy to fix and may be the cause of most of your problems so tackle that first. At the grub menu, select Edit, and where the text says quiet splash, change it to quiet splash pci=noaer

That should allow you to boot. If that fixes the error, you will need to sudo nano /etc/default/grub and add the same option to the default command line.

Let me know if you need better step-by-step instructions.

2
  • see my recent edits to my question. Thanks! – Kestrel Oct 19 '20 at 2:23
  • I advise that you check the output of dmesg to make sure that the log isn't being spammed with AE_NOT_FOUND messages. – nospam Oct 19 '20 at 4:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.