0

I have a Dell vostro 5590, which overheats under Kubuntu 20.04 (the CPU cores reaching 90+ degrees regularly, so is the package temperature, fans working often at top speed).

I currently have BIOS version 1.8.2, and I have seen here that the newest version is 1.11 (from the 1st of September 2020). Thus, I hope that if I upgrade my bios to the newest version, it will be fixed.

In this article, Dell are suggesting to create a blank bootable device, and to move the bios-upgrade .exe file to it, booting into the bios (using F12) and updating.

This far, I have tried to create a live USB using:

  1. The KDE partition manager, deleting all partitions and making one partition using FAT32.
  2. Using rufus on windows to create a bootable device using freeBSD (a long shot).
  3. Using diskpart according to the steps here changing from ntfs to FAT32.

So far, when I reach the bios, it doesn't seem to recognize this as a bootable device, in any of the cases above, and when I'm trying the "Upgrade BIOS" option in the BIOS, I get nothing (no option to choose a file or anything active...).

Remark 1: from the same USB I was installing Kubuntu 20.04 on this machine, so it is working, checked it out before this process.

Remark 2: I have the dell recovery utility on another USB drive, and it recognizes it, and even boots into it.

4
  • Have you a spare usb to try with it? Oct 18 '20 at 22:07
  • @schrodigerscatcuriosity No, my only "spare" USB is holding the dell recovery utility, and is much older. As I said, I was able to boot from it just before I have tried these steps.
    – Kerek
    Oct 18 '20 at 22:18
  • I suggested this because something similar heppened to me, and using a different usb solved the problem. Oct 18 '20 at 22:21
  • @schrodigerscatcuriosity unfortunately I don't have another one...
    – Kerek
    Oct 18 '20 at 22:25

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.