2

My Intel WiFi AX200 - MSI X570 wireless network adapter recently stopped working. I'm running Ubuntu 20.04.

uname -a; dmesg | grep iwl

Linux adrian-MS-7B93 5.4.0-51-generic #56-Ubuntu SMP Mon Oct 5 14:28:49 UTC 2020 x86_64 x86_64 x86_64 GNU/Linux
[    3.526169] iwlwifi 0000:28:00.0: enabling device (0000 -> 0002)
[    3.648129] iwlwifi: probe of 0000:28:00.0 failed with error -110

sudo lshw -C network

  *-network                 
       description: Ethernet interface
       product: I211 Gigabit Network Connection
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:26:00.0
       logical name: enp38s0
       version: 03
       serial: 00:d8:61:bc:3a:68
       size: 1Gbit/s
       capacity: 1Gbit/s
       width: 32 bits
       clock: 33MHz
       capabilities: pm msi msix pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=igb driverversion=5.6.0-k duplex=full firmware=0. 6-2 ip=192.168.1.17 latency=0 link=yes multicast=yes port=twisted pair speed=1Gbit/s
       resources: irq:24 memory:fc600000-fc61ffff ioport:d000(size=32) memory:fc620000-fc623fff
  *-network UNCLAIMED
       description: Network controller
       product: Wi-Fi 6 AX200
       vendor: Intel Corporation
       physical id: 0
       bus info: pci@0000:28:00.0
       version: 1a
       width: 64 bits
       clock: 33MHz
       capabilities: pm msi pciexpress msix cap_list
       configuration: latency=0
       resources: memory:fc500000-fc503fff

I tried adding the Intel® Wi-Fi 6 AX200 160MHz .ucode firmware file to /lib/firmware from Intel's website with no luck.

I also tried a fresh 20.04 installation. One common item between others that I see having this issue is that they also dual boot Windows. The weird thing is I used Ubuntu 20.04 for 3+ months, and then swapped back to Windows for a few days, and upon booting back up in Ubuntu it no longer works. Switched back to Windows again to verify that the device actually works, which it still does.

4
  • 2
    Is this a possible issue? wireless.wiki.kernel.org/en/users/drivers/… Welcome to Ask Ubuntu. – chili555 Oct 18 '20 at 23:52
  • 1
    Excellent! Disabling Fast boot in Windows worked. Thank you! – Adrian Elder Oct 19 '20 at 0:25
  • Awesome! Glad it’s working. – chili555 Oct 19 '20 at 3:09
  • @AdrianElder I had the same problem and this worked for me too. Please add it as an answer and accept. It will help others to find it. – Jasper Nov 6 '20 at 12:17
2

I was able to fix this by disabling Fast boot in Windows:

https://help.uaudio.com/hc/en-us/articles/213195423-How-To-Disable-Fast-Startup-in-Windows-10

2
  • any idea why this works? I just had the same issue and this fixed it (I think) – Vince W. Jan 11 at 22:53
  • I believe fastboot allows Windows to hold onto resources for faster boot times, which conflicts with other operating systems using those same resources. – Adrian Elder Jan 11 at 22:55

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.