0

I've been having an issue with Steam Play and Vulkan for a while now. I switched to Ubuntu, and found out quickly that I could run Windows games on Linux using Steam Play. I remember specifically that I was using Proton 5.0-9, or some version that constantly used DXVK. The games ran extremely well, and I was pleasantly surprised by the fact they performed even better on Linux. But overnight, the games stopped working. They crashed the PC every time I tried to open them. After a while of research, I figured out there was something wrong with Vulkan. So it was either I didn't play the games, or I used Direct3D. But Direct3D has some awful performance. So, I chose not to play. After some thinking, I'm sure I figured out the problem. See, I like playing games in 4:3 black bars, but games like TF2 only played in stretched. (I found out I can just change resolution settings.) I decided I needed to open the AMD Driver settings and turn off GPU scaling. In the end, I didn't find it. So I decided to install another version of the AMD Drivers using the terminal. They didn't work, but it was around then when my games started to crash when I tried to open them. And it just clicked in my head, these non-Default drivers were the problem. It explains everything. So the question is how would I get rid of these user-installed drivers, and rollback to Ubuntu's default drivers? I'm gonna do some more research on this, but any help will be appreciated.

  • How did you "install another version of the AMD drivers"? – waltinator Oct 17 at 23:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.