26

I didn't install anything myself, but only Ubuntu 12.04 LTS on an Acer 4741g.

I use Fn+left/right to change the brightness, but failed.

How can I control the brightness levels?

  • I may have a guide in hebrew with the sources of it. you need? or you got a solution? Here: fxp.co.il/showthread.php?t=10255235&p=94282824#post94282824 Try using Google to translate all the page. Or, try the sorce at the end og tne manual. – yinon Feb 26 '13 at 14:18
  • Nothing worked software and settings-wise for me. Installing a different driver for the graphics did the trick. Go to software center, install "additional drivers" if you don't see a "additional drivers" tab already visible in system settings / software sources. – user147315 Apr 6 '13 at 16:22
  • For followers, this is an "intel" gpu, not nvidia at all... – rogerdpack Jun 18 at 21:27

14 Answers 14

40

Try this:

  1. Open a terminal (Ctrl + Alt + T).
  2. Then type sudo nano /etc/default/grub. It will ask for your password. Type it in.
  3. Around the 11th line, there will be something like: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash". Change it to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
  4. Save the file by Ctrl+O followed by Ctrl+X. Then run sudo update-grub in the terminal.
  5. Reboot and see if backlight adjustment works. If not, undo the changes you did above, by invoking the text editor as in steps 1 and 2.

Hope it helps.

Works for Acer Aspire v3-571,Acer Aspire v3 571g,Hewlett Packard Bell EasyNote TS,Acer Aspire 4755G,Acer Aspire 5750-6866, Acer Aspire 5739, Lenovo T540p

  • To richy: i tried just ago it still didn't work. and if i press Fn+"left" , it will turn from the full to half . i press again, it will turn empty. it changes but the brightness doesn't change. and if i change it (also it won't work), but the next time, the brightness will be different from this time..... – homelesser Apr 30 '12 at 11:22
  • @homelesser what do you mean when you say that brightness will be different from this time? You mean after a reboot, or something else? And another thing, did you update your system after installing ubuntu? if not, try updating it as well. – Richard Apr 30 '12 at 20:03
  • Thank you! I have a Packard Bell EasyNote TS, and the backlight was stuck at full everytime I was using Ubuntu. Did exactly what you said up there, rebooted, and boom, adjustable backlight. Thank you. – user70540 Jul 2 '12 at 20:03
  • I tried this on my Aspire 4755G and it worked! Thanks! – ultrajohn Jul 4 '12 at 3:32
  • 2
    works perfectly with full control on Acer Aspire V3-571G – AhHatem Sep 28 '12 at 16:38
13

OP reported in Revisions 2 & 3 of the question that the following worked for him.

I figured it out from different sites, it fixes backlight.

Run the following command in Terminal:

gksu gedit /etc/default/grub

then change

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

to

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"
GRUB_CMDLINE_LINUX="acpi_osi=Linux"

then save and run:

sudo update-grub 

and then restart the system for changes to take effect.

  • 3
    It worked for me, on Acer Aspire One 756-1007Ckk, but only after a restart. – Florin Apr 23 '13 at 15:40
  • acer aspire e1-570g on Lubuntu worked too! – Tebe May 30 '14 at 3:05
11

Ubuntu 14.04 (13.10+) with intel graphics

How to check if graphics card is intel

First, check if your graphics card is intel. You can check it from System Settings->Details->Graphics or with following command:

ls /sys/class/backlight

You should see something like:

ideapad  intel_backlight

Fix backlight

Make sure /usr/share/X11/xorg.conf.d/20-intel.conf exists. If it doesn't, make it yourself and add the following:

Section "Device"
        Identifier  "card0"
        Driver      "intel"
        Option      "Backlight"  "intel_backlight"
        BusID       "PCI:0:2:0"

EndSection

Logout and Login. Done.

Thanks to Abhishek

Reposted a solution that worked for me http://itsfoss.com/fix-brightness-ubuntu-1310/

  • Worked for Acer Aspire 3820T. Thanks a lot! – Hrundik Apr 18 '15 at 20:53
  • Worked for Acer Aspire 5334 with intel graphics. – Pieter Sep 1 '16 at 12:35
6

[Like in richy's, but] I use GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi="

(I'm on an Aspire 5750-6866.) It works fine, same control levels I had in Windows.

My brightness used to be stuck at max before I discovered this.

(Although brightness levels still reset after a restart/hibernate/shutdown)

  • I'm also on an Aspire 5750. richy's solution had no effect, but this ended up working! Finally! My eye's we're starting to melt. – leighton Jan 11 '13 at 6:24
2

I found out a solution that worked with my laptop:

add this to /etc/rc.local:

echo 2 > /sys/class/backlight/acpi_video0/brightness
2

I had the same problem. I have a Travelmate P633-V and I did this code to fix it.

After installing the scripts my FN-Left and FN-Right are working fine.

The script should work with all intel devices that exposes /sys/class/backlight/intel_backlight

https://github.com/codingtony/acer-brightness-linux-acpi

1

I got this problem when i upgraded from 11.10 to 12.04. enter this in terminal code:

sudo gedit /etc/default/grub

Check for these lines GRUB_CMDLINE_LINUX_DEFAULT and change it as the below and save it.

After the update the grub

code: sudo update-grub

Code:

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
`**GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset acpi_backlight=vendor"**`
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console
# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1" 
1

Most simple and fast way to do this.... Use this command

xrandr --output LVDS1 --brightness 0.5

Set the value in between 0 to 1 like in this case it is 0.5 This works for me Try this !!!

  • 1
    This does change the brightness, but only by means of software, not hardware (i.e.: the level of backlight of laptops doesn't change, only the brightness of the colors) – Koen Sep 27 '13 at 12:48
1

Whilst trying xbacklight didn't work for me because I'm using NVIDIA drivers, Light did the job pretty well for me.

After installing:

  • Increase backlight brightness by 5 percent

    light -A 5
    
  • Decrease backlight brightness by 5 percent

    light -U 5
    
0

Try the following:

sudo gedit /etc/default/grub

Then change this line: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash" to GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" Then in a terminal type sudo update-grub Reboot and see if the problem is solved.

0

(Defunct) solution for Ubuntu 12.04.1:

Use Add Drivers / Additional Drivers to load Cedar Trail drm driver (closed source).


For Ubuntu 12.04.2 (and fully updated 12.04) this issue is resolved by more recent updates. It does not require the proprietary driver.

If you have just done a fresh install of 12.04.2, then you need to update (and re-start) to fix this.

At terminal, type sudo apt-get update && sudo apt-get upgrade and then sudo apt-get dist-upgrade.


Update: (28-Apr-2013)

Repeated steps, with fresh install. This did not fix problem.

While the brightness is fixed, any dimness/brightness adjustment (using function keys) does not seem work after this fix ..

Ongoing ...

0

I was struggling with this problem as well. My notebook is an Acer Aspire E1-522. I could solve the brightness issue by changing from the X.Org X server to the proprietary AMD video driver.

To do so, go to Software & Updates and then go to the tab Additional Drivers. There you can probably find the proprietary driver. Select it and click Apply Changes. You will need to reboot you computer in order to know if it really helped.

0

On Acer Aspire 4740 after installing Ubuntu 18.04, Screen brightness would not change. Tried every thing above, did not help.

Added blacklist acer-wmi to /etc/modprobe.d/blacklist.conf and rebooted

The Fn shortcut started working.

Reference: https://ubuntuforums.org/archive/index.php/t-2172282.html

  • Added the following in /etc/default/grub GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_osi=Linux acpi_backlight=vendor" – Vigyani Sep 30 '18 at 14:43
0

Same solution as one-liner

For this solution, no nano knowledge is required. As such, it may also come handy for multi-machine installation scripts.

sudo sed -i 's|^GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"|GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"|' /etc/default/grub && sudo update-grub

For the faint of heart, the above command edits the file /etc/default/grub to replace the appropriate line with GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor"

After editing, a sudo update-grub should be issued for the changes to take effect.

  • We should not encourage users to run commands like this. Especially if they cannot even work with nano. This is also not useful to more technical users, because it "obfuscates" what is really going on, and it will not work if you have other non-standard grub parameters. – Galgalesh Dec 5 '14 at 10:51
  • 1
    @Galgalesh "Treat all users with respect." You should urgently read The impact of the Linux philosophy. "The entire Unix philosophy revolves around the idea that the user knows what he or she is doing." "Unix was not designed to stop its users from doing stupid things, as that would also stop them from doing clever things." – Serge Stroobandt Dec 5 '14 at 12:24
  • If I phrased my comment disrespectfully, I'm sorry for that. English is a second language to me, I do not mean to be disrespectful. There is a big difference between permitting people to do stupid things and encouraging people to do stupid things. Linux still allows people to wget a random script from the internet and run it. That does not mean we should post it as a solution. Your answer is dangerous, does not educate the user, and is not future-proof. No matter what the Linux philosophy might be, this is not a good askubuntu answer. – Galgalesh Dec 5 '14 at 14:22
  • Firstly, the above command does not load any script from the internet; it does exactly the same as other solutions mentioned here. Secondly, this answer is educational as it shows how a system administrator would roll out this solution to numerous machines. It saves time and avoids any typing mistakes. Again, do not make any assumptions. Many people here run more than just a single instance of Ubuntu on a single machine. System administrators also come to SE to look for answers. Do not put a limit on yourself or others! – Serge Stroobandt Dec 6 '14 at 11:41
  • This is an excellent method, once the correct settings have been identified. It would allow a non-technical user to load the required settings. However, it may not be the correct solution for any given user. – david6 Mar 6 '15 at 0:02

protected by Community Sep 1 '12 at 7:16

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.