2

I can't get Visual Studio Code to update on Ubuntu 20.04. I'm currently on 1.49.x of Visual Studio Code and attempting to upgrade to 1.50.x

Previously (I recently upgraded to 20.04 from 18.04) the updates were a part of the normal updates I would see along with all other updates. Now I only see the update within Visual Studio Code and I am forced to manually download it.

What I've Tried

I tried downloading the deb manually and attempted to install by double-clicking. When I did that then the Snap-Store (Ubuntu Software) would start up and show me I have Visual Studio Code 1.49.x installed but wouldn't allow me to choose the new version to update.

How can I install the update?

1 Answer 1

1

I found the details to work through this at:

https://code.visualstudio.com/docs/setup/linux

I still had some challenges.

The way I was finally able to install the update was to run it directly from the command line :

sudo apt install ./<file>.deb
  1. First download the new .deb
  2. then run the command shown above (using the file name of the deb you downloaded) and the install will actually run.

This is the only way to get it done.

If you double-click the deb and try to run it, it will only show you the current version installed like:

snap store

This shows the correct version because I didn't get a snapshot with the previous version. However, the install will not run by double-clicking the deb.

3
  • 1
    For any downloaded .deb file, it is better to use the sudo apt install command rather than installing it by double clicking on the file.
    – Tanvir
    Commented Oct 17, 2020 at 17:38
  • @Tanvir good to know, thanks. I'm a bit of a Linux newbie and all of the install stuff is only beginning to sink in.
    – raddevus
    Commented Oct 17, 2020 at 18:58
  • I followed sudo apt install and it worked. But trying updating via Ubuntu Software worked as well, so now I have two VSC icons in the applications menu each opening new instances of VSC every time I click on them. How do I remove one of the VSC applications only? Commented Aug 18, 2022 at 9:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .