I was updating my Ubuntu 18.04 to 20.04.1 LTS. But forgot to plug my laptop to charging. My laptop battery died in middle of upgrade. When I turned my laptop on, it started getting stuck on ubuntu logo screen. I googled for some solutions, tried some of them.

  • Like going in Advanced Options for Ubuntu through GRUB and running in recovery mode, selecting dpkg to fix package issues. That stuck on a line saying "e2scrub_all.service is a disabled..." something.

  • Selecting newer kernel gives "end kernel panic: not syncing vfs unable to mount root fs on unknown block (0,0)"...

  • Selecting older kernel recovery mode and selecting resume normal boot continues to get stuck on some blinking underscore forever.

  • When pressing E on Ubuntu in GRUB to edit configuration, I don't see the last line of initrd which I saw in many solutions.

  • selecting a kernel in non-recovery mode showed some line below ubuntu logo that said something like "WARNING: option 'size' missing in crypttab for plan dm-crypt..."

Edit: My laptop is HP with EUFI dual boot with Windows 10 and Ubuntu 20.04

I have posted all of the things I've tried... Please help me in the right direction.

1 Answer 1


The middle of a release-update is the worst possible time to lose power. This is precisely why the release-upgrade tools advise you to plug in your system before proceeding.

Sometimes it's recoverable. However, your description seems to indicate an incompatible, unbootable mix of old and new packages and incomplete configs.

Advice: Wipe your system and reinstall.

  1. Create a new 20.04 LiveUSB Installer on a different, working system.
  2. Use the "Try Ubuntu" environment to backup your data to some other media.
  3. Clean-install 20.04
  4. Restore your data from the backup

Doing this correctly can take a full afternoon (instead of the 40 minutes-or-so for a normal release-upgrade). That's the price you must pay for neglecting to plug in.

  • I had dual booted Ubuntu alongside Windows 10. Is there a way I can access my Ubuntu files from Windows? Oct 18, 2020 at 6:04
  • Try this question access Ubuntu files from Windows: askubuntu.com/questions/9933/…
    – user535733
    Oct 18, 2020 at 11:33
  • Or boot a live CD, mount the partition which had /home on it and start making a backup to another USB drive. You're mainly interested in the /home directory and everything in it - the system's config will have to be redone. Once you have a good backup, start the re-install. If /home is on a seperate partition, you may be able to just install 20.04 and have you computer back to work.
    – Adriaan
    Oct 18, 2020 at 12:29
  • I created a new Ubuntu 20.04 Live USB and booted with it. Clicked on Try Ubuntu. Now when I open the files I see my home directory is empty. The data I wanted to backup was in home directory... How can I get it now? Is there some way? Oct 24, 2020 at 10:21
  • Yes I'm not talking about home directory of LiveUSB. I'm meant the home directory of the hard drive partition that had Ubuntu installed earlier (/dev/sda6). That's empty too. I had so many folders in my home directory. Specially my Android project code. I wanted that. Also, I have an external SSD which I will be copying my files to. Please help Oct 24, 2020 at 10:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .