3

I have just purchased an Hitachi LG-BH16NS40 bluray drive which came mounted in an external USB3 caddy (a Vantec 5.25 inch enclosure). I can't get Ubuntu to mount any discs that I insert into the drive.

The enclosure takes a USB3 connection to the PC and an external power supply.

My PC is running Ubuntu 20.04 LTS. When I connect the external drive to the computer, the output of sudo lshw -C disk gives the following under *-cdrom:

*-cdrom
       description: DVD-RAM writer
       product: BD-RE  BH16NS55
       vendor: HL-DT-ST
       physical id: 0.0.0
       bus info: scsi@6:0.0.0
       logical name: /dev/cdrom
       logical name: /dev/cdrw
       logical name: /dev/dvd
       logical name: /dev/dvdrw
       logical name: /dev/sr0
       version: 1.02
       capabilities: removable audio cd-r cd-rw dvd dvd-r dvd-ram
       configuration: status=nodisc

So the drive is being recognised by the OS. However, when I insert a DVD disc into the drive, the disk is not mounted. The blue activity light on the caddy flashes continuously and the disc is never made available.

I have tried connecting the drive and enclosure to a laptop running Windows 10. Here, the device functions as expected and the same disk mounts straight away upon insertion. The blue activity light on the caddy flashes twice and then goes solid, as I understand is intended.

I have tried different USB ports on my Linux machine. If I restart the computer with a disk in the external drive, Ubuntu hangs on a black screen and never boots.

I should say that I have many other USB devices which I use routinely with the same Ubuntu PC and have never had a problem with any of them.

Any help with this would be much appreciated.

2

I fixed it.

sudo apt install udftools

and a reboot and the device now works as intended.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.