1

As per subject I'm trying to install the drivers version 455 on Ubuntu 20.04. I have enabled the ppa:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update

And I can see the drivers as package nvidia-graphics-drivers-455. But when I try to install them with

ema@scv:~$ sudo apt install nvidia-graphics-drivers-455

I get:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package nvidia-graphics-drivers-455

Output of update and dist-upgrade

ema@scv:~$ sudo apt update && sudo apt dist-upgrade 
Hit:1 http://gb.archive.ubuntu.com/ubuntu focal InRelease
Hit:2 http://gb.archive.ubuntu.com/ubuntu focal-updates InRelease
Hit:3 http://gb.archive.ubuntu.com/ubuntu focal-backports InRelease
Hit:4 http://archive.canonical.com/ubuntu focal InRelease
Hit:5 http://ppa.launchpad.net/graphics-drivers/ppa/ubuntu focal InRelease
Hit:6 http://ppa.launchpad.net/lutris-team/lutris/ubuntu focal InRelease                                    
Hit:7 http://security.ubuntu.com/ubuntu focal-security InRelease                                                                     
Hit:8 https://dl.winehq.org/wine-builds/ubuntu focal InRelease                                                                       
Hit:9 https://download.virtualbox.org/virtualbox/debian focal InRelease 
Reading package lists... Done                           
Building dependency tree       
Reading state information... Done
All packages are up-to-date.
N: Skipping acquisition of configured file 'contrib/binary-i386/Packages', as repository 'https://download.virtualbox.org/virtualbox/debian focal InRelease' doesn't support architecture 'i386'
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

Now I'm getting the package nvidia-driver-455, but it tells me the following:

ema@scv:~$ sudo apt install nvidia-driver-455
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies.
 nvidia-driver-455 : Depends: libnvidia-gl-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: nvidia-dkms-455 (<= 455.23.04-1) but it is not going to be installed
                     Depends: nvidia-dkms-455 (>= 455.23.04) but it is not going to be installed
                     Depends: nvidia-kernel-source-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-extra-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: nvidia-compute-utils-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-decode-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-encode-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: nvidia-utils-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: xserver-xorg-video-nvidia-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-cfg1-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-ifr1-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Depends: libnvidia-fbc1-455 (= 455.23.04-0ubuntu0~0.20.04.1) but it is not going to be installed
                     Recommends: libnvidia-compute-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
                     Recommends: libnvidia-decode-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
                     Recommends: libnvidia-encode-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
                     Recommends: libnvidia-ifr1-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
                     Recommends: libnvidia-fbc1-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
                     Recommends: libnvidia-gl-455:i386 (= 455.23.04-0ubuntu0~0.20.04.1)
E: Unable to correct problems, you have held broken packages.

Not sure what's going on. Has anyone any Idea why this would happen?

Thanks!

  • Where did you get this nvidia-graphics-drivers-455? – Pilot6 Oct 17 at 10:15
  • Is sudo apt-get update running without errors? show us please. – nobody Oct 17 at 10:24
1

The original issue is because if one has multiple entries of

ppa:graphics-drivers/ppa

In the global ppa list, it may not display nvidia-driver-455. After that got cleaned, I was able to see the meta package.

It would not install because I had version 450, hence the following commands did the trick:

sudo apt remove nvidia-driver-450
sudo apt install nvidia-driver-455

And now it's all fine.

The first issue (duplicate ppa entry) made me go crazy for a while.

| improve this answer | |
1

The solution for me was to manually remove every single CURRENT VERSION of the packages that have but it is not going to be installed status.

So I had driver version 440. I had to remove sudo apt purge libnvidia-gl-440 and so on for all of them. After that the error went away.

| improve this answer | |
New contributor
helpless child is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.
0

The correct command is

sudo apt install nvidia-driver-455
| improve this answer | |
  • Which ppa should have it? Looks like is not listed also? – Emanuele Oct 17 at 10:16
  • The PPA you've added has it. – Pilot6 Oct 17 at 10:17
0

The following worked for me:

sudo apt dist-upgrade

after reboot the XOrg driver was active. Now i selected the 455 driver in the SoftwareUpdater and that installed and activated the 455 driver.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.