5

I use gnome tweaks to switch my left CTRL and ALT keys. This has been working fine since 18.4, and I had no issues since upgrading to 20.4 until today...

When I open the settings I can see the checkbox to swap the keys is still ticked. When I untick the checkbox and reapply it the key bindings work - for around 5 minutes. Then for no apparent reason reverts back to default. I've even tried leaving the window open - I can see it remain checked, wait for it to no longer apply, it's still ticked, I untick and re-tick it and it works again

Any help for how I can troubleshoot this is much appreciated.

  • It appears that the daemon is actually crashing. The workaround is to start Tweaks again. Super annoying, watching this for any progress as it seems to be the only report so far. – Chaim Eliyah Oct 17 at 16:34
  • 1
    Scratch that, that only works for... like you said, 5 minutes. I don't have to tick the box though. – Chaim Eliyah Oct 17 at 17:26
  • Marking this as something I would like to have a solution for too. Since I upgraded to 20.04 (from clean 18.04) my Compose-Key settings (Caps Lock) keep resetting. Sometimes settings do persist across restarts. – Reign of Error Nov 12 at 17:46
  • Maybe corrupt $HOME/.config/dconf/user – nobody Nov 23 at 13:13
1
+50

Seems like this may be the same as https://bugs.launchpad.net/ubuntu/+source/mutter/+bug/1899206

If so, it will be fixed in Gnome 3.38.2

| improve this answer | |
  • While this link may answer the question, it is better to include the essential parts of the answer here and provide the link for reference. Link-only answers can become invalid if the linked page changes. - From Review – Nmath Nov 24 at 17:57
  • 2
    @Nmath This is not a link-only answer, as the actual answer is that the problem is a bug which will be fixed in a specific release and the link to the bug report is provided for reference. – BeastOfCaerbannog Nov 24 at 19:30
  • This may be related, but I am using a wireless keyboard with Bluetooth, similar to yotama9. I'll watch this closely today, someone may as well get the bounty. Everyone's a critic. :) – Chaim Eliyah Nov 25 at 19:38
  • Done. I do think that we could probably clean this up a little bit with an explanation of how it's related and maybe a command line workaround. If I have extra time over the next few days I'll submit an edit. Thanks! – Chaim Eliyah Nov 26 at 18:43
1

In my case, I narrowed it down to plugging in an external keyboard via USB. Even though the external keyboard has the same layout (UK QWERTY) as the laptop, my compose key and CAPS LOCK key settings are reset. It's annoying, but re-selecting the options in Gnome-Tweaks fixes it.

According to this question, this is specific to the version of GNOME currently being used in Ubuntu 20.04. There is a corresponding bug registered for GNOME, which should be fixed in an upcoming release. According to the other discussion, there is a workaround, restarting the gnome session after connecting the keyboard:

A quick workaround is to restart the shell after plugging in the external keyboard by pressing Alt-F2, r, return.

This is quite possibly the same bug identified in the existing answer, just registered in different places.

| improve this answer | |
  • 1
    It's listed as a duplicate. I am still not sure what plugging in a new serial device has to do with losing the setting for Bluetooth, but I will trust them that it is related. – Chaim Eliyah Nov 27 at 17:57

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.