I have Ubuntu Server 10.10 running on Parallels 6 (latest update from yesterday) on my iMac. I click on the Install Parallels Tools in the Parallels Desktop Menu, but do not see where what I think should be the file prl-tools-lin.iso is placed.

Don't understand whether the warning that I may have to do mount -o exec applies to me or not. Think I might be able to mount and run the .iso file, if I can locate it. Any ideas?

4 Answers 4


I have solved this issue with Ubuntu Server 18.04 as follows:

1) Click "Update Parallels tools" (upper right corner of the parallels virtual machine window)

2) Log in and then give the commands:

$ sudo mount /dev/cdrom /media/cdrom
$ cd /media/cdrom
$ sudo ./install

If, when mounting the CD-ROM, you get the error:

mount: /media/cdrom: unknown filesystem type 'iso9660'

you can fix this using:

$ sudo apt-get install --reinstall linux-image-$(uname -r)
  • 1
    This was the one that worked for me, except I used sudo mount /dev/cdrom /cdrom Oct 22, 2020 at 7:48

With Parallels 10.1.1 and Ubuntu 14.04 using the menu entry Actions -> Install parallels tools... did not mount the installer in /media/parallels. Trying sudo updatedb; locate prl-tools-lin.iso also returned an empty result.

The solution is to cd /usr/lib/parallels-tools then sudo ./install, which will execute the text installer. Incidentally sudo ./install-gui (from the same directory) will execute the GUI installer (requires X server).


To find a file on your compute you can use the built in index, from a command line:

sudo updatedb; locate prl-tools-lin.iso

But really to answer this question we need to go to the guides:

Select Actions -> Install parallels tools...
In a terminal, enter:
cd /media/Parallels\ Tools/
sudo sh parallels-tools.run

If this fails to work then you can get the iso file and mount it manually like so:

sudo mount -o loop /path/to/prl-tools-lin.iso /mnt

Don't forget to unmount it when you're finished:

sudo umount /mnt

  • I've seen the same thing in Ubuntu, 10.04, 10.10 and 11.04. The image does not mount when selecting Install Parallels Tools. I have to locate the prl-tools-lin.iso file on my machine, then execute sudo mount -o loop /path/to/prl-tools-lin.iso /media/cdrom
    – user25252
    Sep 19, 2011 at 18:04
  • A note for newer versions of Ubuntu & Parallels: You can specify the prl-tools-lin.iso in the CD-ROM at the bottom of the window (set the disk image you want in the preferences), and the path is /media/<USERNAME>/Parallels\ Tools/ and the executable you want now is called install.
    – CyberSkull
    Sep 24, 2014 at 11:01

If you're using Parallels 6+ instead of typing: "sudo sh parallels-tools.run" you will probably need to type "sudo sh install" without the quotation marks.

  • 1
    From what directory?
    – belacqua
    Nov 7, 2012 at 1:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy