2

I am following this guide which says:

wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-ubuntu1804.pin

sudo mv cuda-ubuntu1804.pin /etc/apt/preferences.d/cuda-repository-pin-600

wget http://developer.download.nvidia.com/compute/cuda/11.0.2/local_installers/cuda-repo-ubuntu1804-11-0-local_11.0.2-450.51.05-1_amd64.deb

sudo dpkg -i cuda-repo-ubuntu1804-11-0-local_11.0.2-450.51.05-1_amd64.debsudo apt-key add /var/cuda-repo-ubuntu1804-11-0-local/7fa2af80.pub

sudo apt-get update

sudo apt-get -y install cuda

I get a cuda-repo-ubuntu1804-11-0-local_11.0.2-450.51.05-1_amd64.deb file.

At the stage of executing the sudo apt-get -y install cuda command I get this output:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following additional packages will be installed:
  cuda-11-1 cuda-command-line-tools-11-1 cuda-compiler-11-1 cuda-cudart-11-1
  cuda-cudart-dev-11-1 cuda-cuobjdump-11-1 cuda-cupti-11-1 cuda-cupti-dev-11-1
  cuda-demo-suite-11-1 cuda-documentation-11-1 cuda-driver-dev-11-1
  cuda-drivers cuda-drivers-455 cuda-gdb-11-1 cuda-libraries-11-1
  cuda-libraries-dev-11-1 cuda-memcheck-11-1 cuda-nsight-11-1
  cuda-nsight-compute-11-1 cuda-nsight-systems-11-1 cuda-nvcc-11-1
  cuda-nvdisasm-11-1 cuda-nvml-dev-11-1 cuda-nvprof-11-1 cuda-nvprune-11-1
  cuda-nvrtc-11-1 cuda-nvrtc-dev-11-1 cuda-nvtx-11-1 cuda-nvvp-11-1
  cuda-runtime-11-1 cuda-samples-11-1 cuda-sanitizer-11-1 cuda-toolkit-11-1
  cuda-tools-11-1 cuda-visual-tools-11-1 dkms libcublas-11-1
  libcublas-dev-11-1 libcufft-11-1 libcufft-dev-11-1 libcurand-11-1
  libcurand-dev-11-1 libcusolver-11-1 libcusolver-dev-11-1 libcusparse-11-1
  libcusparse-dev-11-1 libnpp-11-1 libnpp-dev-11-1 libnvidia-cfg1-455
  libnvidia-common-455 libnvidia-compute-455 libnvidia-decode-455
  libnvidia-encode-455 libnvidia-extra-455 libnvidia-fbc1-455 libnvidia-gl-455
  libnvidia-ifr1-455 libnvjpeg-11-1 libnvjpeg-dev-11-1 libxnvctrl0
  nsight-compute-2020.2.0 nsight-systems-2020.3.4 nvidia-compute-utils-455
  nvidia-dkms-455 nvidia-driver-455 nvidia-kernel-common-455
  nvidia-kernel-source-455 nvidia-modprobe nvidia-prime nvidia-settings
  nvidia-utils-455 screen-resolution-extra xserver-xorg-video-nvidia-455
Suggested packages:
  menu
Recommended packages:
  libnvidia-compute-455:i386 libnvidia-decode-455:i386
  libnvidia-encode-455:i386 libnvidia-ifr1-455:i386 libnvidia-fbc1-455:i386
  libnvidia-gl-455:i386
The following packages will be REMOVED:
  libnvidia-compute-450-server
The following NEW packages will be installed:
  cuda cuda-11-1 cuda-command-line-tools-11-1 cuda-compiler-11-1
  cuda-cudart-11-1 cuda-cudart-dev-11-1 cuda-cuobjdump-11-1 cuda-cupti-11-1
  cuda-cupti-dev-11-1 cuda-demo-suite-11-1 cuda-documentation-11-1
  cuda-driver-dev-11-1 cuda-drivers cuda-drivers-455 cuda-gdb-11-1
  cuda-libraries-11-1 cuda-libraries-dev-11-1 cuda-memcheck-11-1
  cuda-nsight-11-1 cuda-nsight-compute-11-1 cuda-nsight-systems-11-1
  cuda-nvcc-11-1 cuda-nvdisasm-11-1 cuda-nvml-dev-11-1 cuda-nvprof-11-1
  cuda-nvprune-11-1 cuda-nvrtc-11-1 cuda-nvrtc-dev-11-1 cuda-nvtx-11-1
  cuda-nvvp-11-1 cuda-runtime-11-1 cuda-samples-11-1 cuda-sanitizer-11-1
  cuda-toolkit-11-1 cuda-tools-11-1 cuda-visual-tools-11-1 dkms libcublas-11-1
  libcublas-dev-11-1 libcufft-11-1 libcufft-dev-11-1 libcurand-11-1
  libcurand-dev-11-1 libcusolver-11-1 libcusolver-dev-11-1 libcusparse-11-1
  libcusparse-dev-11-1 libnpp-11-1 libnpp-dev-11-1 libnvidia-cfg1-455
  libnvidia-common-455 libnvidia-compute-455 libnvidia-decode-455
  libnvidia-encode-455 libnvidia-extra-455 libnvidia-fbc1-455 libnvidia-gl-455
  libnvidia-ifr1-455 libnvjpeg-11-1 libnvjpeg-dev-11-1 libxnvctrl0
  nsight-compute-2020.2.0 nsight-systems-2020.3.4 nvidia-compute-utils-455
  nvidia-dkms-455 nvidia-driver-455 nvidia-kernel-common-455
  nvidia-kernel-source-455 nvidia-modprobe nvidia-prime nvidia-settings
  nvidia-utils-455 screen-resolution-extra xserver-xorg-video-nvidia-455
0 upgraded, 74 newly installed, 1 to remove and 0 not upgraded.
Need to get 22,1 MB/2 553 MB of archives.
After this operation, 5 581 MB of additional disk space will be used.
Do you want to continue? [Y/n]

All of which are Cuda 11.1 packages.

What am I doing wrong?

2

To Install cuda 11.0 run:

sudo apt-get install cuda-11-0
2
  • He asked 11.1 !
    – Thư Sinh
    Aug 14 '21 at 3:17
  • so why he installed the 11.0 repo? Jan 15 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.