I'm trying to connect to my Ubuntu VPS (8 core CPU, 24gb ram) using Windows 10 Remote Desktop Connection. I followed the instructions here:


It's virtually impossible to do anything. It's so slow it nearly takes 15 seconds for something to happen like typing in the console or openening up the browser. I went through many threads here with similar problems but did not have any success.

I tried the latest Ubuntu version as well with no luck.

My Linux knowledge is very limited so will appreciate some assistance here.

Any idea whatI can try next ?

  • 1
    For a VPS living on the Internet, crypt_level = low is a spectacularly bad idea. The man page xrdp.ini(5) states "This is the only level that the traffic sent by the server to client is not encrypted." Additionally, max_bpp=128 is going in the wrong direction from the default of 32. When I replace the default max_bpp=32 with max_bpp=8, I get a huge boost in performance at the expense of poorly rendered colors on the remote desktop. For server administration, the tradeoff is well worth it. May 25, 2021 at 19:17

1 Answer 1


The default settings for an XRDP installation are not optimized. To increase XRDP performance try the following:

Make a backup of the configuration file:

cp /etc/xrdp/xrdp.ini /etc/xrdp/xrdp.ini.bck

Now edit the configuration file:

nano /etc/xrdp/xrdp.ini

Inside the file edit the variables "max_bpp", "xserverbpp" and "crypt_level", these are optimized values:

max_bpp = 128
xserverbpp = 128
crypt_level = low

It is convenient to add the variable "max_bpp" the variable "use_compression" with the following value:

use_compression = yes

Finally, when connecting low, lower the color quality to 16 bits instead of 32 bits.

  • This definitely helped but it's not close to the performance I get on Windows servers...
    – ceds
    Oct 16, 2020 at 12:21
  • 3
    I hope you guys are reading the manual. The maximum value for max_bpp is 32. Also Xorg only supports up to 24 bits per pixel, so the same goes for xserverbpp. If you are running an Xorg session (which is most likely the case for many), you gain nothing from changing either of these values.
    – smac89
    Jul 3, 2021 at 1:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.