0

Update: to anyone having a similar issue read the comments for the solution

I have a dual boot system and a few partitions distributed along 3 HDDs in my case. They all mount automatically on my KDE at startup and I've never had any problems with deleting, creating or transferring files between them, but all of a sudden my write permissions have been denied. Which is pretty weird considering that the output for ls -l for all of my partitions still gives me this:

alex@alex-ubuntu:/media/alex$ ls -l
total 148
drwxrwxrwx 1 alex alex 65536 Oct 12 18:14 Backup
drwxrwxrwx 1 alex alex  4096 Mar 30  2019 DCC68E14C68DEF58
drwxrwxrwx 1 alex alex  4096 Oct 12 18:14 Downloads
drwxrwxrwx 1 alex alex  4096 Oct 12 18:14 Games
drwxrwxrwx 1 alex alex  4096 Oct 12 18:14 Videos
drwxrwxrwx 1 alex alex  8192 Oct 12 19:11 Windows

Not even sudo commands for copying or creating files are working anymore:

alex@alex-ubuntu:/media/alex/Videos$ sudo touch test.txt
[sudo] password for alex: 
touch: cannot touch 'test.txt': Read-only file system
alex@alex-ubuntu:/media/alex/Videos$ 

I've done some research but all the similar cases I've found were those where the user didn't have full permission or root still had the ownership, so it was almost as simple as using chmod or chown to address the issue. I have absolutely no clue on what could've been causing this, especially given that my external HDD still works flawlessly when connected, for instance.

Here's the mount output:

alex@alex-ubuntu:~$ mount
sysfs on /sys type sysfs (rw,nosuid,nodev,noexec,relatime)
proc on /proc type proc (rw,nosuid,nodev,noexec,relatime)
udev on /dev type devtmpfs (rw,nosuid,noexec,relatime,size=2994076k,nr_inodes=748519,mode=755)
devpts on /dev/pts type devpts (rw,nosuid,noexec,relatime,gid=5,mode=620,ptmxmode=000)
tmpfs on /run type tmpfs (rw,nosuid,nodev,noexec,relatime,size=607456k,mode=755)
/dev/sdc5 on / type ext4 (rw,relatime,errors=remount-ro)
securityfs on /sys/kernel/security type securityfs (rw,nosuid,nodev,noexec,relatime)
tmpfs on /dev/shm type tmpfs (rw,nosuid,nodev)
tmpfs on /run/lock type tmpfs (rw,nosuid,nodev,noexec,relatime,size=5120k)
tmpfs on /sys/fs/cgroup type tmpfs (ro,nosuid,nodev,noexec,mode=755)
cgroup2 on /sys/fs/cgroup/unified type cgroup2 (rw,nosuid,nodev,noexec,relatime,nsdelegate)
cgroup on /sys/fs/cgroup/systemd type cgroup (rw,nosuid,nodev,noexec,relatime,xattr,name=systemd)
pstore on /sys/fs/pstore type pstore (rw,nosuid,nodev,noexec,relatime)
none on /sys/fs/bpf type bpf (rw,nosuid,nodev,noexec,relatime,mode=700)
cgroup on /sys/fs/cgroup/memory type cgroup (rw,nosuid,nodev,noexec,relatime,memory)
cgroup on /sys/fs/cgroup/cpu,cpuacct type cgroup (rw,nosuid,nodev,noexec,relatime,cpu,cpuacct)
cgroup on /sys/fs/cgroup/devices type cgroup (rw,nosuid,nodev,noexec,relatime,devices)
cgroup on /sys/fs/cgroup/rdma type cgroup (rw,nosuid,nodev,noexec,relatime,rdma)
cgroup on /sys/fs/cgroup/blkio type cgroup (rw,nosuid,nodev,noexec,relatime,blkio)
cgroup on /sys/fs/cgroup/hugetlb type cgroup (rw,nosuid,nodev,noexec,relatime,hugetlb)
cgroup on /sys/fs/cgroup/freezer type cgroup (rw,nosuid,nodev,noexec,relatime,freezer)
cgroup on /sys/fs/cgroup/cpuset type cgroup (rw,nosuid,nodev,noexec,relatime,cpuset)
cgroup on /sys/fs/cgroup/perf_event type cgroup (rw,nosuid,nodev,noexec,relatime,perf_event)
cgroup on /sys/fs/cgroup/pids type cgroup (rw,nosuid,nodev,noexec,relatime,pids)
cgroup on /sys/fs/cgroup/net_cls,net_prio type cgroup (rw,nosuid,nodev,noexec,relatime,net_cls,net_prio)
systemd-1 on /proc/sys/fs/binfmt_misc type autofs (rw,relatime,fd=28,pgrp=1,timeout=0,minproto=5,maxproto=5,direct,pipe_ino=434)
hugetlbfs on /dev/hugepages type hugetlbfs (rw,relatime,pagesize=2M)
debugfs on /sys/kernel/debug type debugfs (rw,nosuid,nodev,noexec,relatime)
mqueue on /dev/mqueue type mqueue (rw,nosuid,nodev,noexec,relatime)
tracefs on /sys/kernel/tracing type tracefs (rw,nosuid,nodev,noexec,relatime)
fusectl on /sys/fs/fuse/connections type fusectl (rw,nosuid,nodev,noexec,relatime)
configfs on /sys/kernel/config type configfs (rw,nosuid,nodev,noexec,relatime)
/var/lib/snapd/snaps/core18_1885.snap on /snap/core18/1885 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/exercism_5.snap on /snap/exercism/5 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/core_9993.snap on /snap/core/9993 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/gtk-common-themes_1506.snap on /snap/gtk-common-themes/1506 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/gnome-3-28-1804_145.snap on /snap/gnome-3-28-1804/145 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/discord_115.snap on /snap/discord/115 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/heroku_3993.snap on /snap/heroku/3993 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/postman_127.snap on /snap/postman/127 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/snapd_9279.snap on /snap/snapd/9279 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/vlc_1700.snap on /snap/vlc/1700 type squashfs (ro,nodev,relatime,x-gdu.hide)
/dev/sdc7 on /home type ext4 (rw,relatime)
/var/lib/snapd/snaps/snapd_9607.snap on /snap/snapd/9607 type squashfs (ro,nodev,relatime,x-gdu.hide)
/var/lib/snapd/snaps/core_10126.snap on /snap/core/10126 type squashfs (ro,nodev,relatime,x-gdu.hide)
tmpfs on /run/user/1000 type tmpfs (rw,nosuid,nodev,relatime,size=607452k,mode=700,uid=1000,gid=1000)
/dev/sda1 on /media/alex/Videos type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdb2 on /media/alex/Downloads type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdb1 on /media/alex/Backup type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdc2 on /media/alex/DCC68E14C68DEF58 type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdc1 on /media/alex/Windows type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/sdc3 on /media/alex/Games type fuseblk (ro,nosuid,nodev,relatime,user_id=0,group_id=0,default_permissions,allow_other,blksize=4096,uhelper=udisks2)
/dev/fuse on /run/user/1000/doc type fuse (rw,nosuid,nodev,relatime,user_id=1000,group_id=1000)
  • 1
    Read-only is different from permission denied. Can you post the output of mount with no arguments? Also, are they Windows drives? – Pixelated Fish Oct 14 '20 at 0:50
  • @PixelatedFish yes, all of them are ntfs/windows drives. I'll edit the original post to include the mount output because of its lenght – Alex Braga Oct 14 '20 at 2:04
  • The mount output confirms that the drive is mounted read-only, so my answer still stands. If they are actual Windows installs, and not just drives that happen to be NTFS for some other reason, you should disable quick start in Windows, though this may not be the only problem. Think linked questions show how to remount a drive as read-write and check for damage with fsck You should not remount as read-write until you have confirmed the drives are not damaged and have disabled quick start, as it can lead to other problems too. (actually, it might be called Windows Fast boot, I don't remember.) – Pixelated Fish Oct 14 '20 at 2:36
  • 1
    @AlexBraga NTFS partitions are bound to have problems with linux eventually. You can periodically, from windows, run a chkdsk on these to avoid problems. – schrodigerscatcuriosity Oct 14 '20 at 11:37
  • 1
    It's also worth noting that if you don't have to store things on a Windows boot volume, you shouldn't use NTFS, as the Linux driver is purely based on reverse engineering. – Pixelated Fish Oct 14 '20 at 13:20
1

Your error message shows that /media/alex/Videos, whichever drive that is, is mounted as read only see here and here. This could be due to a system error, or (though more prevalent in external drives) the drive locking itself due to a hardware error. If this is the case, you should back up your data soon, as the hard drives may become corrupted or cease to function. If there is not a problem with the drive, check for bad entries in /etc/fstab

Edit from comments (so it doesn't get deleted)

As it turns out, they were NTFS drives, some with windows installed. The solution stated as working by the OP was to simply log back in to Windows and perform a proper shutdown, then reboot into Linux. For anyone else having this problem, you should make sure to shutdown your computer properly, and disable Windows Fast Boot, as it can prevent you from accessing Linux and cause other problems as well.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.