After upgrading to 12.04, my Logitech M515 does not work here is some output from the terminal:


Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 001 Device 003: ID 0411:002a BUFFALO INC. (formerly MelCo., Inc.) 
Bus 001 Device 004: ID 055d:3021 Samsung Electro-Mechanics Co. 
Bus 002 Device 002: ID 413c:2005 Dell Computer Corp. RT7D50 Keyboard
Bus 004 Device 002: ID 0582:0074 Roland Corp. EDIROL UA-25
Bus 005 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver

dmesg | grep Logitech

[   30.470528] logitech-djreceiver 0003:046D:C52B.0004: hiddev0,hidraw1: USB HID v1.11 Device [Logitech USB Receiver] on usb-0000:00:1d.3-2/input2

The cursor does not move. Also the mouse was working in 11.10 and is working in Windows NT 5.1.2600.

| improve this question | | | | |
  • When you say it does not work what exactly is happening?, your receiver is being recognized - have you checked your mouse battery? FWIW I have a M510 working perfectly under 12.04. – Mark Rooney Apr 30 '12 at 8:41

Here's the clean workaround for this problem. A part of the solution has already been given.

Explanation: instead of having to type in modprobe -r hid_logitech_dj && modprobe hid_logitech_dj each time you startup linux we will make a very simple startup script that implements these two commands. To make sure it starts up at boot we put it in the init.d folder.

To make sure everybody can follow it I will tell step by step what to do.

  1. Make a file named:

  2. Open that file (by clicking on it) and add these lines:

    modprobe -r hid_logitech_dj
    modprobe hid_logitech_dj
  3. Open the terminal and make sure you navigate to the folder where 'logitech-unifying.sh' is located. Then type this command:

    sudo mv -i logitech-unifying.sh /etc/init.d
  4. Enter your password

  5. Close the terminal

  6. Reboot

When you startup linux, your logitech unifying device should be working.

| improve this answer | | | | |
  • NICE first answer, +10 if I could. Perfectly formatted even. Welcome to Ask Ubuntu! – Tom Brossman Oct 18 '12 at 21:49
  • I tried this but it didn't work for me. The unifying receiver in my setup seemed to need something more brutal. See @Helter's links and my comments there for more info. – Bobble Oct 26 '12 at 20:06

the problems you are seeing with the unifying receiver is likely due to a bug documented here:


and/or here (depending on if these are dups or not.. they seem to be, but have different reported hardware configurations.. so.. ymmv)


| improve this answer | | | | |
  • As I note in comments to @Thomas' solution, I found the workaround documented in these links was at least partially successful. I still need to unplug and re-plug the receiver on reboot, but at least the keyboard and mouse end up working. – Bobble Oct 26 '12 at 20:09

I had the same problem with B605 Logitech mouse after upgrading to 12.04. I had to re-plug the usb receiver to start mouse working. What I did was two commands:

modprobe -r hid_logitech_dj
modprobel hid_logitech_dj

Now mouse is working after boot.


| improve this answer | | | | |
  • Some how it solved it self. Maybe the mouse power switch has to be on during boot but I have not tried it. Thanks for help. – user877329 May 3 '12 at 5:47

I realize this may be somewhat late to the game, but for those of you (like me) who basically had to run that modprobe command every single time you boot your computer (which on a laptop, is quite often), I made a project on GitHub specifically to take care of this:


Instructions are on the site, but basically you install it and when the computer boots, just keep moving your mouse left and right until it starts moving on screen, and that's it.

Let me know if this worked for anybody.

| improve this answer | | | | |

If you start the PC with the unifying dongle plug in, the mouse and or keyboard must not be on, wait 10 seconds after login, and then turn on ONE device at the time, waiting 10 sec between them. Use same methodng if you plug in the dongle after the system is booted. Works 100% for me! Annoying but works great, just put a 10 sec delay befor the drive looks for HID device should do the trick.

| improve this answer | | | | |

I have the same problem with a m505 Logitech wireless mouse where the mouse will not be recognized. The battery has been checked and been replaced to rule out power issues. The particular issue I have will resolve if I unplug the receiver dongle and plug it back in. I think this would do similar action as the above modprobe remove and reload action.

| improve this answer | | | | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.