1

My laptop is a Lenovo X1 Carbon 7th gen, running Ubuntu 18.04. While working really late last night, I fell asleep and my laptop ran out of battery. In the morning I put the charger in, but although the lights were pulsating, indicating hibernation, it didn't want to wake up. I therefore held the power button, forced a restart and ever since my battery has stayed at 0% and estimating.

There is no issue in removing the charger, and the laptop runs fine. The laptop has no removable battery. Also, if I boot up in Windows 10 (installed on its own partition) and hover the mouse above the battery indicator, it says "Unknown" or "255% remaining". Clearly something is off.

I have googled and searched the forum for answers without luck. I have included the output of the commands typically suggested in other threads.

$ acpitool -B
  Battery #1     : present
    Remaining capacity : 0 mWh, -nan%, -1.00% of design capacity
    Capacity loss      : 101.%
    Present rate       : 0 mW
    Charging state     : Unknown
    Battery type       : Unknown 
$ acpi -V
Battery 0: Unknown, 0%
Adapter 0: on-line
Thermal 0: ok, 53.0 degrees C
Thermal 0: trip point 0 switches to mode critical at temperature 128.0 degrees C
Cooling 0: Processor 0 of 10
Cooling 1: B0D4 no state information available
Cooling 2: Processor 0 of 10
Cooling 3: x86_pkg_temp no state information available
Cooling 4: Processor 0 of 10
Cooling 5: Processor 0 of 10
Cooling 6: INT3400 Thermal no state information available
Cooling 7: Processor 0 of 10
Cooling 8: pch_cannonlake no state information available
Cooling 9: Processor 0 of 10
Cooling 10: iwlwifi no state information available
Cooling 11: Processor 0 of 10
Cooling 12: intel_powerclamp no state information available
Cooling 13: Processor 0 of 10
Cooling 14: SEN1 no state information available
cat /proc/acpi/battery/BAT0/alarm
cat /proc/acpi/battery/BAT0/info
cat /proc/acpi/battery/BAT0/state
cat /proc/acpi/battery/BAT1/alarm
cat /proc/acpi/battery/BAT1/info
cat /proc/acpi/battery/BAT1/state
cat /proc/acpi/processor/CPU0/throttling

All of the above commands give the following output:

No such file or directory

I also ran these commands:

$ cat /sys/class/power_supply/BAT0/alarm
0

$ cat /sys/class/power_supply/BAT0/status
Unknown

$ cat /sys/class/power_supply/BAT0/capacity
0

$ cat /sys/class/power_supply/BAT0/capacity_level
Critical

Furthermore, I tried updating the firmware, where I had to use a force flag, because it said the battery needed to be at least 30% charged:

sudo apt update && sudo apt upgrade -y
sudo service fwupd start
sudo fwupdmgr refresh
sudo fwupdmgr update --force

Any help and understanding on how to solve this is very appreciated!


I can see that this question is still getting many views, so I thought it might be a good idea to do an update, since my problem has been fixed by other means.

UPDATE: After a couple of months with the issue periodically returning, I ended up calling my local authorized Lenovo repair shop. They replaced my motherboard since they couldn't even detect the battery with their monitoring programs, and could therefore not debug anything. A new motherboard seems to be what I needed, because everything works fine now. It also makes sense since I could see my issue was persistent across different operating systems. When the battery would act weirdly, it would do so across Ubuntu, Windows, Debian. So it was most likely not software related. Since neither BIOS nor Firmware updates helped it was more or less the last thing to try. I got mine replaced for free, since it was still under warranty, so it was no matter what worth a try.

3
  • 1
    Unplug the laptop from AC power, shutdown the computer if it's running, hold down the POWER key for one minute. This should reset the Power Manager. Replug AC and check the battery again. You may need to charge the battery again for it to read correctly. Report back. – heynnema Oct 13 '20 at 21:20
  • This worked for me! I have verified that the percentage goes up when charging, and also down when unplugged and discharging. Could you please change your comment to an answer so i can close the question? Perhaps you could elaborate why this error occurs, so I and others stumbling across this post can learn from it. Thank you very much for your help. – Yuki Oct 13 '20 at 22:47
  • Answer done! Thanks for the update. Glad it worked for you. – heynnema Oct 13 '20 at 23:18
1

From the comments...

The Power Manager controls all power in/out of the computer. Sometimes it gets confused.

Shutdown the computer if it's running, unplug the laptop from AC power, hold down the POWER button for one minute. This should reset the Power Manager. Replug AC and check the battery again. You may need to charge the battery again for it to read correctly.

Update #1:

Also updated the BIOS to version N2HET57W (1.40).

11
  • I am sad to say that the issue was only fixed temporarily using this approach. It works for some time, and then reverts back to 0% with same issues as before. There does not seem to be any pattern in when the problem occurs after resetting the power manager. – Yuki Oct 16 '20 at 22:50
  • @Yuki OK, try this. Reset the power manager. Charge up the battery. Remove AC power. Leave the laptop running on battery until the battery is dead (Don't let it sleep). Hold down the POWER button again for 1 minute. Re-plug AC. Recharge Battery. Retest. – heynnema Oct 17 '20 at 0:12
  • Thank you for the quick reply. I am currently testing this out. I'll report back when done. – Yuki Oct 17 '20 at 8:55
  • I have now finished the procedure. It is somewhat difficult to say whether or not it has worked yet, since the battery indicator was working fine whilst waiting for the battery to drain completely. Hopefully it will keep working this time. For others trying this fix, I can tell that my laptop wanted to force hibernation when reaching critical battery status of about 5%. I simply woke it up, logged in again and waited for it to reach 0% and turn of. After pressing the power button for 60 seconds and powering re-plugging AC, the laptop was actually in hibernation mode as i opened the lid. – Yuki Oct 17 '20 at 22:46
  • It has unfortunately reverted back to showing 0%. The weird thing is, that it started out working fine for an hour or two. Another interesting thing is, that I just pressed the lock-screen icon, waited 2 seconds and logged back in, and the battery is now showing the correct percentage. Why does it work so inconsistently? – Yuki Oct 18 '20 at 10:34
1

I had this same issue a couple days ago. Lenovo X1 Carbon 7th gen, running Ubuntu 18.04. I left my laptop charging while I was at work and when I came home, it said the battery was at a critical level and at 0%. I left it plugged for a couple hours and it still said the battery was at 0%.

I tried restarting the computer, letting the battery drain completely and letting it charge up again, resetting the power manager. None of these work unfortunately. I thought it might be an issue with TLP, since I have it installed.

I found a GitHub issue (https://github.com/linrunner/TLP/issues/151) with TLP on Mint 17.2 and one of the last ditch attempts to fix the issue was to update the kernel.

I ran the following command:

sudo apt install linux-generic

And let the machine install the latest updates for the kernel, and boom, the battery was recognized and displayed a percentage that wasn't 0%.

Not sure that this will fix the issue for you, but it might be worth giving it a shot.

2
  • This seems unrelated to Ubuntu, as linux-generic is always preinstalled, and kernel updates are automatic. It does seem related to Linux Mint, as they've bragged about disabling kernel updates in the past. Anyway, you should now get kernel updates without interference. – mikewhatever Oct 25 '20 at 16:55
  • That is interesting. I was already running kernel version 5.3.0-40-generic and it was sufficient to update the BIOS to the most recent version 1.40. It is worth mentioning that I was generally also experiencing issues with waking the laptop up from sleep. Every once in a while, it would not wake up, and I needed to hold the power button down, potentially loosing unsaved work. It seems that this issue too has been fixed after my recent BIOS update. – Yuki Oct 26 '20 at 9:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.