16

I have installed Ubuntu server 12.4 in Oracle Virtual box, after completing installation, i cant use the Ubuntu server in full screen,guest additions present in virtual box will work in ubuntu server.

29

You can have the ubuntu server console in VirtualBox start at a resolution that your graphic card supports via the virtualbox environment.

Quick Steps

  • Check the resolutions your graphic card supports via the VirtualBox Environment (VBE).You should be able to find that out by issuing the command 'vbeinfo' in the GRUB console (hit the C key when the GRUB boot menu shows up).

  • Pick one resolution, then open '/etc/default/grub' (e.g. sudo vim /etc/default/grub) and change the line #GRUB_GFXMODE=640x480 to something like this GRUB_GFXMODE=1152x864 (where 1152x864 should be your custom resolution which is also supported by your graphic card).

  • Now run these two commands one-by-one:

    sudo update-grub
    sudo reboot
    

You should now see your VM's console in the custom resolution that you just set.

(PS: As Javier Rivera said, full screen resolution may not be possible.)

11

As mentioned in Proper way to change terminal resolution in Ubuntu Server 13.04? you also need to set

GRUB_GFXPAYLOAD_LINUX=keep

in the /etc/default/grub file otherwise the resolution is only briefly used during boot

  • 1
    i confirm this is needed for Ubuntu Server 16.04 LTS – Jeff Xiao Jun 6 '16 at 15:01
9

What I always do is install ssh on the server and then use putty to access the server. Not only does this allow me to view the server in full screen, it also allows me to connect to it from other machines.

to install ssh metapackage (client and server) just run:

sudo apt-get install ssh

You could install only openssh-server if you don't need the ssh client on the VM.

  • 2
    How does this answer the question? – Olli Feb 23 '14 at 18:35
  • 4
    @Olli it serves the same purpose - having a full screen CLI. – guntbert Feb 23 '14 at 18:38
  • 2
    this is the easiest way to achieve the exact same thing the OP is requesting. – Anthony Aug 12 '16 at 20:52
9

Other answers didn't work properly for me on Ubuntu 16.10 - e.g. resolution would be applied, but then reverted at various points later during boot. What did eventually work was the combination of the following three settings in /etc/default/grub:

GRUB_GFXMODE=1280x1024  # width x height required - see below
GRUB_CMDLINE_LINUX_DEFAULT="nomodeset"
GRUB_GFXPAYLOAD_LINUX=keep

Followed by running:

sudo update-grub
sudo reboot

NOTE: Supported resolutions can be identified from within grub. Hit C at the grub prompt, then type:

set pager=1    (To enable paging of long vbeinfo output)
vbeinfo
reboot         (When done)

When selecting a resolution, width x height is sufficient (unless you specifically care about setting colour depth too).

  • On 16.04, GRUB_CMDLINE_LINUX_DEFAULT="nomodeset" was a requirement to get the resolution to change. – MacroMan Oct 23 '17 at 13:04
2

The VirtualBox guest additions display driver only works on graphical mode, not text mode. You will need to install Xorg to use it full-screen.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.