1

The brightness control are not working on Ubuntu 12.04 64-bit , Sony Vaio VPCY2 ( Intel video card) . I've tried both ways Fn+F5/F6 and from Brightness/Lock menu (under Settings) - I can slide the brightness adjustment bar but nothing changes so it looks like the brightness controls are not working at all.

Anyone know if there is a workaround for this ?

1

1) Open a terminal

2) type this: gksudo gedit /etc/X11/xorg.conf

3) Enter your password; a text editor will appear, find the following lines:

Section "Screen"
       Identifier     "Screen0"
       Device         "Device0"
       Monitor        "Monitor0"
       DefaultDepth    24
       Option         "RegistryDwords" "EnableBrightnessControl=1"
   SubSection     "Display"
       Depth       24
   EndSubSection
EndSection

4) make this line look like this or add it if it dosen't exist:
Option "RegistryDwords" "EnableBrightnessControl=1"

5) close & save changes (Be careful before saving you can take down your system, if you're not sure that you didn't do anything wrong choose "don't save"!!

6) Restart computer.

  • There is no file in /etc/X11/xorg.conf in Ubuntu 12.10 , also there is not file xorg.conf on the entire system. – Dinu Feb 24 '13 at 16:18
0

I am Having Vaio VGN-FZ340E and it didn't work WITH THIS SOLUTION

AND SOLVED following this link

http://ubuntuforums.org/showthread.php?p=11910629#post11910629

Not the answer you're looking for? Browse other questions tagged or ask your own question.