I have two monitors (1920x1200 and 2550x1600) and ati card (hd 4870x2). I installed the ati drivers from additional drivers panel. Unfortunately ulike in previous versions of ubuntu I am unable to set the proper resolutions for my two monitors. I get the message: The desktop cannot be created because its area is too large.

Have you encountered this problem. What is the possible solution.


You need to define your 2 screens in AMD soft.

  1. Open ATI driver application

    enter image description here

  2. and define your 2 screens display without any limit.

    amd settings

  3. and re-boot

  4. you might see no changes, but to end the manipulaation, use then the normal Screen application to set your 2 screens.
    And for new Ubuntu behaviors too like:

    • unity toolbar on only screen, or on both (in english it's got to be "launcher position")
    • mouse stuck on screen border (in english it's got to be "sticky border")

enter image description here

  • I do it that way and that's excatly where I get the error – greg606 Apr 30 '12 at 21:13
  • Are you sure that the driver is well installed? Try fglrxinfo. See help.ubuntu.com/community/BinaryDriverHowto/… – Boris May 1 '12 at 6:31
  • yes, it is installed well – greg606 May 1 '12 at 7:04
  • Thanks Boris, it worked for me! I had several Compiz crashes in the process, but at the end I got two monitors running. The only problem I still have is that the mouse sometimes "stucks" at the connection point of two monitors, and it needs a couple of seconds in order to continue moving to the other monitor. – Degvik May 1 '12 at 12:06
  • 1
    @Degvik: it is made in purpose that the mouse stucks in the connection between the 2 screens, to remove this behaviour, turn off the last option in the Ubuntu Screen application (I added screen shot in my answer - sorry in french) – Boris May 1 '12 at 12:20

I have the same issue on a 27 inch iMac running Ubuntu 12.04 64bit. It has an ATI Mobility Radeon HD 4850 in it.

I get the same exact error message if I attempt to set the two monitors to their max resolution, and then arrange them side by side.

A couple of retarded workarounds are to move the second monitor below the first, as apparently the complete desktop resolution of the two combined at this arrangement is accepted.

Through some testing I found that the max Desktop Area width seems to be 4000, and I am going to guess the max height is also 4000. It is not a total area calculation either, as I can arrange the monitors in such a way as to use more total screen area than the normal arrangement would, and that is allowed.

Seems to be something that limits it to 4000.

Another things that worked for me, is to rotate my second monitor so that it is vertical, this reduced the width enough to make the resolution acceptable. This doesn't work very well for me, as my second monitor looks very bad vertical due to the viewing angle design of the monitor.

I found that you can forcibly set the resolution via the xorg.conf however, this doesn't work. The section of the screen area beyond 4000 becomes corrupted.

  • you run ubuntu on imac? that's interesting. that makes windows obsolete.... – greg606 Apr 30 '12 at 20:28
  • ... except for the fact that Windows 7 doesn't have this problem. – H2ONaCl May 1 '12 at 11:52
  • I did not mention this earlier. But this issue did NOT exist in prior versions of the FGLRX driver that came with Ubuntu. The fglrx package(but not the fglrx-updates package) that came with 11.10 did not have the issue. I may be misstating the versions. But I did try to update my drivers in 11.10, and the newest version had the issue, and I had to rollback, though I am not sure exactly which versions worked and which didn't. I plan to do some more testing today. I'm sure there is an available driver version that I can get working. – user58874 May 2 '12 at 16:51
  • One extra note. I typically use this iMac by running Kubuntu with a Windows 7 VM setup in dual monitor seamless mode using VirtualBox. Have to use a lot of windows for administrative and development work in the company, since it is a mostly windows company. – user58874 May 2 '12 at 17:09
  • Evidently this problem is peculiar to specific cards. 12.04 gave me no trouble whatsoever running 3 monitors horizontally at 1600x900 each (cumulative greater than 4000) on a 58xx series. – RobotHumans Aug 2 '12 at 2:37

There are two solutions I've found to the same problem.

Solution 1. Disable proprietary driver. Reboot. Now go to Settings > Displays and uncheck the "mirror displays" box. You may also wish to alter the "launcher placement" setting so that you have one launcher on one monitor, not an additional one on the 2nd monitor. You may also wish to disable "sticky edges" so that your mouse won't catch when moving between the two monitors.

Solution 2. This is a clarification of Boris's answer who recommends using the AMD/ATI control panel, but his image was in French and there are more details needed. If you're really set on running the proprietary driver, open AMD Catalyst Control Center (I use the Administrative version, not sure if that's required or not). Then you'll need to set the two monitors to have nothing to do with each other... not mirroring, and not multi-desktop. Just single. Then reboot. THEN in the next page down in Catalyst Control Center's option pages, enable Xinerama, and reboot again.

In some cases the latter solution doesn't work. For example in my current situation, something wasn't allowing me to dissociate the two monitors... they kept getting forced into cloning. I was allowed to change the setting, but as soon as I closed the application the setting was lost.

  • have a look here askubuntu.com/a/81016/32413, there is a clone setting in ~/.config/monitors.xml. Perhaps this way you ll keep your settings. – Boris May 1 '12 at 10:33
  • I know of solution 1 but it sucks. GPU is loud and not using all its powers. Solution 2 doesn't work. – greg606 Jun 13 '12 at 19:02

Latest (v12.4) directly from AMD's site fixed this dual monitor resolution issue for me. I have HD4850. I presume that Jockey is offering older version.

  • Unfortunately it doesn't fix it for me. – greg606 Jun 13 '12 at 18:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.