I upgraded to 12.04 LTS and ran Software Center while a few things were running, and crashed. (2 GB RAM on a Netbook.)

On reboot, Ubuntu One interface would not find any programs, neither installed (to run) nor available for download. So I launched Software Center, which opens, but does nothing. I click "Close" button and get a "Force Quit?" box. So I quit.

Did research, learned to run Software Center from Terminal:

2012-04-29 23:14:36,978 - softwarecenter.backend.reviews - WARNING - Could not get usefulness from server, no username in config file

Then tried the below without success:

Reinstallation of software center:

sudo apt-get install --reinstall software-center

Didn't work. Found this in a post: remove the config file for software-center then log out and back in

sudo rm -rf ~/.config/software-center

Didn't work. Reinstalled Software Center with Synaptic Package Manager. Still no dice!

And I am a Linux newbie, so I don't know where the Dickens that config file is. Help appreciated.


3 Answers 3



cd ~/.cache; rm -r software-center

in a terminal.

Credits to Joker Dino :P


I have been seeing pretty much exactly the same thing, seeing the same problems in the same version (fresh Ubuntu 12.04). I tried similar things and they also didn't work for me. Apparently there are other software installers available, as suggested in the answer to this thread.

I found an answer on my computer! It was a variation on the reinstallation solution above, which I applied when trying to solve another problem which turned out to be a side effect of this one. The cause, for me, was apparently something in the Ubuntu Software Center cache, messing up both it and the Dash search. So another thread got me to do what worked for me, which was this:

rm ~/.cache/software-center -R
unity --reset &
  • worked for me without the unity --reset &
    – amc
    Feb 25, 2013 at 1:12

Adding a community-wiki answer based on one of the comments on a duplicate question.

Add /usr/lib/policykit-1-gnome/polkit-gnome-authentication-agent-1 to the Startup applications.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .