I've been trying to create a short-cut key for grabbing part of the screen.

If I run the command /usr/bin/gnome-screenshot --area the program I want runs and does what I want. When I createa a custom action in the keyboard shortcuts menu, and I activate the command (using ctrl-prnscr) the command fires up but behaves as though the --area option isn't there (it grabs the whole screen instead of giving me a cursor to choose with). If I run ps -eaf |grep screen I get:

$ ps -eaf |grep screen
yfarjoun  2082     1  0 Oct29 ?        00:00:21 gnome-screensaver
yfarjoun 17730     1  0 17:34 ?        00:00:00 gnome-screenshot --area
yfarjoun 17735 17730  1 17:34 ?        00:00:00 gnome-screenshot --area
yfarjoun 17741  2599  0 17:34 pts/0    00:00:00 grep --color=auto screen

So the option is definitely transfered to the command....

Why is it not honoring the option? How can I fix this?


It works for me when pressing the shortcut twice (fast).

This seems to have worked at some point but doesn't anymore (see this thread at ubuntuforums.org - it doesn't work for me, with or without the '-i' switch).

There's already a bug report opened: https://bugs.launchpad.net/ubuntu/+source/gnome-utils/+bug/549935

| improve this answer | |
  • This is also a bug in fedora, for which using the command sh -c "sleep 0.02; gnome-screenshot --area" works. – Yossi Farjoun Aug 26 '11 at 14:50

In 12.04 (at least), the default shortcut is Shift+PrtScr.

| improve this answer | |

An alternative is to use Shutter and:

  1. Set Preferences -> Advanced to start with the selection size and location you want.
  2. Set Preferences -> Keyboard to Capture with Selection.

When you press your shortcut key the screen will freeze and the default selection will be made. You can either press Enter to accept the screenshot, Esc to cancel or adjust the selection manually.

You can save different default selections as profiles. It has other nice features, such as basic editing and configurable filenames too.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.