I'm on an Acer Aspire E5 and I haven't been able to get my laptop's onboard keyboard and trackpad to work, although the trackpad is detected as a Synaptics, and the keyboard is showing as an AT Translated Set 2 keyboard. External mouse and keyboard works fine, and are what I am currently using.

I already checked whether I'm on Synaptics or Libinput, although I was fairly certain that upgrade happened a few years ago, and I am definitely using libinput, which I reinstalled, to no avail. I've made sure that the trackpad is enabled in the system settings, and I've switched it from advanced mode to basic in the BIOS, which for some seemed to have been the solution

I'd like to note that the onboard keyboard works fine on boot, and its only when X is loaded (i'm assuming) that it fails.

I have just recently installed Kubuntu on this machine after grappling with the same issue on Arch, thinking i had done something wrong in the installation. On Arch, I had no trouble using the keyboard on the TTY and live-USB (Arch and Ubuntu), but when i installed X for a GUI, they both stopped working.

What should my next steps be?

  • I only have part of the problem, i.e., flaky touchpad. It's an ALPS PS/2 DualPoint TouchPad. I also have the ALPS PS/2 DualPoint Stick, which works fine. Since I have two almost identical computers and and both started the problem at about the same time, I knew it probably was a software problem. To be sure, I went to the bios before booting, and the touchpad worked fine. I just tried both fixes referenced above, reverting to 5.4.0-42 and blacklisting intel_vbtn, and neither worked. There are lots of recent posts with the problem here, and very few answers - maybe someone can cosolidate these. Oct 13, 2020 at 20:29
  • FWIW, here's an interesting extra piece. A few days ago, I changed to a backlit keyboard on one of my computers. When I initially rebooted everything was fine. By the end of the session, the problem was back. Go figure. One comment said it was a kernel issue that was fixed on 2020-10-10. Maybe it will show up in package updates soon. I hope so. The kernel archive site says the last update was 2020-10-07. Oct 13, 2020 at 20:29
  • Kernel update just came out,, and my problem disappeared. Hooray! Update: Just like the keyboard change out, it worked fine for a few minutes after the kernel upgrade and reboot, then the problem returned. Darn. It's not as bad as before, though. It was always intermittent and jumpy. Now, it's less jumpy. Oct 14, 2020 at 2:28

1 Answer 1


There is a bug in recent kernels that disables some laptop keyboards. Mainly Acer and HP so far. Can usually go to recovery and boot from kernel 5.4.0-42 or use an external keyboard.

Blacklisting the intel_vbtn kernel module is a workaround for this, as seen in Why my laptop's keyboard screwed up since kernel 5.4.0-47 till 5.8.0-20

To implement this, you can either create a new file in /etc/modprobe.d with the suffix .conf or use the main blacklist.conf file. The former may be preferable, since you can then just delete the file when it is no longer required (i.e. when the bug is fixed):

sudoedit /etc/modprobe.d/blacklist-intel_vbtn.conf

Add a line to the file, optionally with a comment explaining why you are doing this

# bug in module breaks keyboard, so don't load it
blacklist intel_vbtn

Save the file, exit and reboot.

  • Wow, I didn't expect that to be the problem, thanks for the link! I ended up blacklisting intel_vbtn in /etc/modprobe.d/blacklist.conf. Reading through the linked post, I just noticed that the only keys that registered for me too were fn+left/right arrow, which change the brightness. Looks like this bug has also been patched in the most recent releases of kernel 5.4 and 5.8, as of October 10.
    – shoebill
    Oct 13, 2020 at 2:28
  • 1
    Thanks to @Zanna for the edit and adding exact code needed.
    – crip659
    Oct 14, 2020 at 10:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.