11

I cannot see where to disable alert sounds on Ubuntu 20.04. I believe it was available under Sound Settings in older versions of Ubuntu. "Alert sound" is there but not a corresponding volume.

  1. Is there an alternative way to do this?
  2. If this is not possible from Settings, who on earth decided that was a good idea? Thanks!
3
  • Hi @user1793956 Welcome to Askubuntu; If my post below wouldn't work; please reply and explain what went wrong //Regards Oct 12, 2020 at 14:20
  • Solution Link. Maybe it can help.
    – MoYa
    Oct 14, 2020 at 15:53
  • @user1793956 did it work? if it did, please don't forget to click the accept button :) have a nice weekend! Jan 8, 2023 at 18:20

3 Answers 3

20

In a terminal, type gsettings set org.gnome.desktop.sound event-sounds false

Note: I do not know (at all) if this is even answering the question; I hope it is helpful anyway; though - have a great day! :)

6
  • 1
    This definitely answers the initial question, and notably works to disable all alert bells, not just the one from the Terminal. It works in Ubuntu 22.04.Thx! Apr 14, 2023 at 1:30
  • @YoannPageaud Happy to be useful! ^_^ please comment if it's some improvement I can do, I thought of making a github repo (bash/py script) to be able to interactively-choose what to en/dis able Apr 14, 2023 at 11:03
  • 1
    You can always make it as a script but since it is a single command, I would consider that an overkill. However maybe there is a repository somewhere where one could open an issue to ask for adding an option to the GUI preferences of Ubuntu where we could easily turn on or off the alert bell everywhere (in Files, in Terminal, etc.). I believe this is not an GUI available parameter yet so that would be useful! Apr 14, 2023 at 12:54
  • 1
    @YoannPageaud ofc! great idea. I'll see what I can do :) Apr 14, 2023 at 14:26
  • 1
    I can confirm that this worked for me on Ubuntu 22.10. It turned off the alert sound in the terminal AND in the system in general. (This is a godsend after the latter didn't work through the Settings application.) Nov 1, 2023 at 11:34
3

I just had the same question, and was able to silence the terminal beep sounds by means of Settings -> Sound -> Volume Levels -> System sounds. You can either use the slider or double clic on the speaker on the right end of the slider.

For William Martens the gsettings command you posted does not change anything.

Edit:

After looking into whether there is a distinction between alert sounds and system sounds I now found this answer How to disable alert sounds on Ubuntu 20.04 that proposes the same solution.

2
  • 3
    gsettings set .. command from William actually worked for my Ubuntu 20.04
    – selyunin
    Jan 6, 2021 at 18:39
  • @selyunin GLAD IT WORKED! thank you! wishes from Sweden! Jul 9, 2022 at 9:34
1

for Ubuntu 20.04 this will definitely work: Settings -> Sound -> Sound Effects tab -> toggle Alert volume off.

enter image description here

1
  • I think this is a good answer as well, +1. sorry for late reply :) Wishes from Sweden! Dec 19, 2023 at 10:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .