0

I'm getting this error since trying to upgrade to Ubuntu 20. For the reference, I never wanted to install ZFS on this computer, never did anything to that effect, and, subsequently, there are no ZFS volumes / pools or anything like that on this computer.

Why is this happening / how can I disable this behavior? I don't have a kernel module for ZFS, so there's nothing to blacklist.

I figured that the effects of whatever kernel is doing there might be benign, I still don't want it to spew suspicious errors.

  • Please clarify your release(s). Ubuntu uses yy releases only for specialist snap based releases for IoT appliances/devices or cloud based use (having done so since 2016). Main releases use yy.mm such as used by server & desktops releases. You mention both Ubuntu 20 (snap based release likely Ubuntu Core 20) but have tagged Ubuntu 20.04 LTS; please clarify. – guiverc Oct 10 '20 at 11:13
2

That isn't a kernel message, that is a message from a systemd service that mounts ZFS file systems. Something like the following should stop it trying to do that:

systemctl disable zfs-mount
systemctl disable zfs-import-cache

Or you could just leave it as is, the message doesn't indicate an actual problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.