I just installed Spotify two days ago and it worked perfectly. After one day, when I started my computer and opened Spotify, it worked ok, but after closing it and opening it again it crashes. A blank screen appears for 1 second and then closes. I have the free version of Spotify and I'm running Ubuntu 20.04.

edit: If I open Spotify from the terminal this happens:

Gtk-Message: 09:29:30.910: Failed to load module "gail"
Gtk-Message: 09:29:30.910: Failed to load module "atk-bridge"
Gtk-Message: 09:29:30.918: Failed to load module "canberra-gtk-module"
[1012/092931.627932:FATAL:gpu_data_manager_impl_private.cc(439)] GPU process isn't usable. Goodbye.
Trace/breakpoint trap (core dumped)

I forgot to say that I recently used an ad blocker. I saw that it's illegal and I removed it. Firstly I tried to remove ads as shown in this video. It didn't work, so I installed "Spotify adkiller", then I saw it's illegal to remove ads from Spotify and I removed it (at least I think so).

I want to mention that if I turn on my computer, the first time I open Spotify it works perfectly, but if I close Spotify and open it again it crashes. It looks like Spotify wants to open but another application opens over Spotify and closes it. Llike a Spotify closer.

  • I am also experiencing this issue on Debian. I am investigating and hope to provide an answer soon. This is not related to your ad-blocking activities.
    – Ivy
    Oct 15, 2020 at 9:30
  • 2
    It does eventually load: while true; do spotify && exit; done
    – Ivy
    Oct 15, 2020 at 9:36

5 Answers 5


I had a same problem but got a fix. Here are some solutions that might work.

  • spotify --disable-gpu --disable-software-rasterizer
  • spotify --no-zygote
  • sudo spotify
  • Or a reboot

while true; do spotify && exit; done eventually loads but most probably you will get black screen and if this happens then second one will work for you.

  • 2
    the --no-zygote worked for me Mar 2, 2021 at 13:58

It is a bug in the Spotify app NOT in Ubuntu's global system. Spotify is based on Chromium (that is no secret I think) , now Chromium has a bug :

you can read all about it here

To help you on your way : open a terminal and simply type: $spotify --no-zygote this way you can close and re-open spotify a lot of times without a fatal crash.

We have to wait thus on a Chromium update for this error, and we have to wait until Spotify will update from this. There is no other way.

Remember that you run Spotify now out of the terminal process !


--no-zygote worked for me, but opening terminal to launch spotify was a no for me. When i clicked the spotify icon spotify didn't launch for some reason so I fixed that problem like this:

I put --no-zygote into spotify.desktop file by changing Exec=spotify %U command to:

Exec=spotify %U --no-zygote

If that doesn't work, right click on spotify icon and open properties, Application tab (I'm using kde so it might differ in each distro, not sure) and change spotify %U to spotify %U --no-zygote in the command section

The second one worked for me.

  • The right click on the icon will not work in Ubuntu's head version, Gnome3. So if there is another way or option I would be glad to hear it. Jun 23, 2021 at 16:46

Yes, I also experienced the same thing, then I reinstalled it. In my experience, don't open spotify via the Linux terminal, you can open it via the application menu. It worked for me.


Open the System Monitor, go to Processes and check if there is still a spotify process running. I haven't used an adblocker but solved a similar issue by simply killing that process.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .