0

Just installed 20.04.1 LTS, it worked before. ran, sudo apt install --reinstall gnome-software, but it did not fix it.

0
0

Why you want gnome-software? You will be having snap store (ubuntu software). If u are inclined to have gnome-software, try removing and purging whole data using command sudo apt-get remove --purge gnome-software then try installing again using sudo aptitude install gnome-software. This should solve the problem.

2
  • Thank you, this has fixed the problem. I don't know if I should want gnome-software. The reason I ran "apt install --reinstall gnome-software" was because I saw it in an old post about someone who seemed to be having a similar problem. All I was trying to do was to fix software center. Software center seems to be now replaced with an icon that looks sort of like a brief case, but works the same as the old software center. Maybe gnome was not what was installed before? Did we just fix what was installed with Ubuntu or did we get rid of the old software center and put a different one in?
    – Chuck J
    Oct 10 '20 at 16:55
  • From ubuntu 20.04, u have snap store (i.e. called as Ubuntu Software) in place of gnome software centre. Sanp store deploys snaps. gnome-store is not installed by default. You can add plugins to gnome-software to have snap functionality or flatpak functionality. Snaps are the way ahead, so it will be prudent to have snap store, instead of gnome-software, though some may not agree. Anyway, glad to know it helped ! Oct 11 '20 at 6:36

Not the answer you're looking for? Browse other questions tagged or ask your own question.