2

Keyboard interaction seems so broken to me the I must be doing something silly.

Simple scenario: <Ctrl>-<Alt>-T and I get a new terminal. I click "Terminal" and "Reset" and the terminal resets. So far, so good.

Same scenario, using only the keyboard: <Ctrl>-<Alt>-T and I get a new terminal. I'd like to access the "Terminal" menu with <Alt>-T, but that doesn't work. If I access it with the mouse, I'd like to trigger "Reset" by typing r. Doesn't work, either. However, if I press a cursor key (up or down), typing r works.

Now, why doesn't <Alt>-T access the "Terminal" menu and why doesn't r run the "Reset" command (without cursor keys to nudge it) and how can I get this very, very, very basic and widely used interaction style to work?

Or to put it another way, I want to "Paste" with <Alt>-E p instead of <shift>-<control>-V. How?

1

You have to enable the option

Edit → Preferences → General → Activate mnemonics

enter image description here


Sorry for the spanish, I couldn't get the terminal in english with LC_ALL=C.

1
  • No worries, Spanish is perfect, as far as I'm concerned, and so is the solution. :) It boggles my mind that a setting like this would even exist, let alone be switched off by default. Anyway, thanks! – Tomislav Nakic-Alfirevic Oct 11 '20 at 8:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.