1

When plugging in a headset via the headphone jack, my laptop sends sound to the speakers but does not pick up any sound from the microphone.

I tried to modify /etc/modprobe.d/sound-fixup.conf by adding

options snd-hda-intel position fix=1
options snd-hda-intel model=aspire-headset-mic

Afterwards I got the option to select between headset and headphones once I plug in my headset, but no sound is detected. I also tried many other settings from this list: https://www.kernel.org/doc/html/latest/sound/hd-audio/models.html

dell-headset-multi and dell-headset-dock gave me similar options to select from when plugging in the headset, but still without sound. All other settings seemed to not work at all.

I also tried my luck with hdajackretask, but I really can't wrap my head around what each setting does and blindly copying things that worked for other people has not worked for me.

Alsa infromation with plugged in headset: http://alsa-project.org/db/?f=8edf11436c3372bcefbc92e020fc87beff178e3d

I would be very thankful for any help!

-1

Have you tried putting your code in /alsa-base.conf? Have you tried checking all your sound card pins viA hdajackretask specifically configuring port 0x19 to microphone?

1
  • Adding it to /alsa-base.conf sadly also does not fix the issue. About pin 0x19: In hdajackretask, I selected the sound card, clicked on "Show unconnected pins", selected "Override" for pin 0x19 and chose Microphone and then clicked "Install boot override". The issue remained. Afterwards, my laptop even stopped recognizing my headset as an input device. Concerning trying the other pins: I have tried changing some of these, but mainly in a random fashion as I could not figure out what does what. Could you maybe elaborate on what the pins and their settings mean? – DoubleHelix Nov 1 '20 at 16:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.