I am trying to use Gparted to extend the partition /dev/sdb5 which I used 47/50 GiB. I have a new empty partition /dev/sdb6 with 200 GiB capacity. I tried to resize/move but this not works.

How can I merge these two partitions into one?

Edit: How can I move entire my data from /dev/sdb5 to /dev/sdb6 in case there is no way to merge 2 partitions?

  • Have you tried to delete the empty partition (/dev/sbd6), resulting in unallocated space of 200 GiB, and then add this unallocated space to partition dev/sbd5? Disclaimer: I have not tried myself whether this would work.
    – Jan
    Oct 9, 2020 at 8:43
  • I tried it already. Gparted just allows me to create a new partition with unallocated space.
    – Thanh Kiet
    Oct 9, 2020 at 8:44
  • Is /dev/sdb5 mounted ? You can't change a mounted partition - if the partition is mounted, there are a little lock symbol at it in gparted. Unmount it if possible, or boot from live media (USB or DVD) and then change the partition size in gparted.
    – Soren A
    Oct 9, 2020 at 9:40
  • @SorenA Yes, /dev/sdb5 mounted to / directory so I cannot unmount it. I have an error: umount / target is busy
    – Thanh Kiet
    Oct 9, 2020 at 9:56
  • @ThanhKiet then read the next part of my comment; boot from Live media ...
    – Soren A
    Oct 9, 2020 at 10:15

1 Answer 1


The easiest way to merge the two partitions is as follows:

  1. Boot the system via a Live USB;
  2. Load up Gparted
  3. Check whether the said partition /dev/sdb6 (with 200 GiB capacity) is listed as free, unallocated space; if not, delete it. It will show as unallocated space.
  4. Unmount partition /dev/sdb5, if mounted.
  5. Resize partition /dev/sdb5 to the capacity you want.

Wait until completed. It should work.

  • I also tried booting via Live USB. In this way, the partition /dev/sdb5 which I need to extend is unmounted but I still can not resize it.
    – Thanh Kiet
    Oct 12, 2020 at 6:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .