1

Below is all what I have tried. I don't know what else to try now to remove the alsa not found error. Please guide.

$ make

Package alsa was not found in the pkg-config search path.
Perhaps you should add the directory containing `alsa.pc'
to the PKG_CONFIG_PATH environment variable
No package 'alsa' found
Package freetype2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `freetype2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'freetype2' found
Package webkit2gtk-4.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `webkit2gtk-4.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'webkit2gtk-4.0' found
Package gtk+-x11-3.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-x11-3.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-x11-3.0' found
Package alsa was not found in the pkg-config search path.
Perhaps you should add the directory containing `alsa.pc'
to the PKG_CONFIG_PATH environment variable
No package 'alsa' found
Package freetype2 was not found in the pkg-config search path.
Perhaps you should add the directory containing `freetype2.pc'
to the PKG_CONFIG_PATH environment variable
No package 'freetype2' found
Package webkit2gtk-4.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `webkit2gtk-4.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'webkit2gtk-4.0' found
Package gtk+-x11-3.0 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gtk+-x11-3.0.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gtk+-x11-3.0' found
Makefile:174: recipe for target 'check-pkg-config' failed
make: *** [check-pkg-config] Error 1

...

$ sudo apt-get install libasound2

Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 libasound2-data : Breaks: libasound2 (< 1.1.3-5ubuntu0.1)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

$ sudo apt-get install libasound2-dev
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 alsa-utils : Depends: libasound2 (>= 1.1.1)
 gnome-settings-daemon : Depends: libasound2 (>= 1.0.16)
 google-chrome-stable : Depends: libasound2 (>= 1.0.16)
 gstreamer1.0-alsa : Depends: libasound2 (>= 1.0.27)
 ibm-java80-jre : Depends: libasound2
 libasound2-dev : Depends: libasound2 (= 1.1.3-5)
 libasound2-plugins : Depends: libasound2 (>= 1.0.27)
 libcanberra0 : Depends: libasound2 (>= 1.0.16)
 libpcaudio0 : Depends: libasound2 (>= 1.0.16)
 libqt5webenginecore5 : Depends: libasound2 (>= 1.0.16)
 libsdl1.2debian : Depends: libasound2 (>= 1.0.16)
 libsndio6.1 : Depends: libasound2 (>= 1.0.17)
 openjdk-8-jre : Depends: libasound2 (>= 1.0.16)
 pulseaudio : Depends: libasound2 (>= 1.0.24.1)
 skypeforlinux : Depends: libasound2 (>= 1.0.16)
 speech-dispatcher-audio-plugins : Depends: libasound2 (>= 1.0.16)
 spice-vdagent : Depends: libasound2 (>= 1.0.16)
 vlc-plugin-base : Depends: libasound2 (>= 1.0.27)
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).

...

$ sudo apt --fix-broken install

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 alsa-utils : Depends: libasound2 (>= 1.1.1)
 gnome-settings-daemon : Depends: libasound2 (>= 1.0.16)
 google-chrome-stable : Depends: libasound2 (>= 1.0.16)
 gstreamer1.0-alsa : Depends: libasound2 (>= 1.0.27)
 ibm-java80-jre : Depends: libasound2
 libasound2-plugins : Depends: libasound2 (>= 1.0.27)
 libcanberra0 : Depends: libasound2 (>= 1.0.16)
 libpcaudio0 : Depends: libasound2 (>= 1.0.16)
 libqt5webenginecore5 : Depends: libasound2 (>= 1.0.16)
 libsdl1.2debian : Depends: libasound2 (>= 1.0.16)
 libsndio6.1 : Depends: libasound2 (>= 1.0.17)
 openjdk-8-jre : Depends: libasound2 (>= 1.0.16)
 pulseaudio : Depends: libasound2 (>= 1.0.24.1)
 skypeforlinux : Depends: libasound2 (>= 1.0.16)
 speech-dispatcher-audio-plugins : Depends: libasound2 (>= 1.0.16)
 spice-vdagent : Depends: libasound2 (>= 1.0.16)
 vlc-plugin-base : Depends: libasound2 (>= 1.0.27)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies

...

$ sudo apt-get -f install   

Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... failed.
The following packages have unmet dependencies:
 alsa-utils : Depends: libasound2 (>= 1.1.1)
 gnome-settings-daemon : Depends: libasound2 (>= 1.0.16)
 google-chrome-stable : Depends: libasound2 (>= 1.0.16)
 gstreamer1.0-alsa : Depends: libasound2 (>= 1.0.27)
 ibm-java80-jre : Depends: libasound2
 libasound2-plugins : Depends: libasound2 (>= 1.0.27)
 libcanberra0 : Depends: libasound2 (>= 1.0.16)
 libpcaudio0 : Depends: libasound2 (>= 1.0.16)
 libqt5webenginecore5 : Depends: libasound2 (>= 1.0.16)
 libsdl1.2debian : Depends: libasound2 (>= 1.0.16)
 libsndio6.1 : Depends: libasound2 (>= 1.0.17)
 openjdk-8-jre : Depends: libasound2 (>= 1.0.16)
 pulseaudio : Depends: libasound2 (>= 1.0.24.1)
 skypeforlinux : Depends: libasound2 (>= 1.0.16)
 speech-dispatcher-audio-plugins : Depends: libasound2 (>= 1.0.16)
 spice-vdagent : Depends: libasound2 (>= 1.0.16)
 vlc-plugin-base : Depends: libasound2 (>= 1.0.27)
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
E: Unable to correct dependencies
2
  • Do you want to install a audio-config program? (I Would personally recommend pavucontrol) ? – William Martens Oct 8 '20 at 19:10
  • I have to compile a JUCE program @William – Aquarius_Girl Oct 8 '20 at 19:26
2

For most users, apt install libasound2-dev would solve the original problem.

As apt-get complains, your installation is somewhat broken:

You have package libasound2-data installed in version 1.1.3-5ubuntu0.1, but apt does not find package libasound2 of the same version.

This may be the result of removing "bionic-updates" from your apt sources. This can e.g. happen if you unselect "Recommended updates" under "Updates" in sudo software-properties-gtk.

In your place, I would do the following: Ensure that your apt sources receive regular updates:

  • Make sure you have recommended updates enabled. Either through sudo software-properties-gtk, or by editing /etc/apt/sources.list to contain a line like

    deb http://de.archive.ubuntu.com/ubuntu/ bionic-updates main restricted
    
  • sudo apt update

After that, your packages should install as expected.

1
  • I will try what you have said. Am thankful to you. – Aquarius_Girl Oct 8 '20 at 20:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.