0

I need to update my kernel in Xenial Ubuntu 16.04 LTS. Existing solutions appear to be outdated or don't work.

(Reason: Blender 2.90.x isn't running due to old display drivers. To update display drivers it's recommended to first upgrade the kernel.)

I've tried installing the Mainline utility,

sudo add-apt-repository ppa:cappelikan/ppa
sudo apt update
sudo apt install mainline

This results in an error:

Reading package lists... Done
Building dependency tree       
Reading state information... Done
E: Unable to locate package mainline

Has the repository for Mainline changed or are there any other good packages out there for managing kernels? Any advice appreciated.

6
  • 16.04 will be coming to end of support soon(next year), have you thought about just upgrading to 18.04?
    – crip659
    Commented Oct 8, 2020 at 15:05
  • Yes, I have a partition with Ubuntu 18.04 installed, but I have other needs and good reasons for sticking to 16.04 that I won't go into.
    – DeXoN
    Commented Oct 8, 2020 at 15:09
  • Upgrade from what kernel? Are you using the GA kernel (4.4) or have you already enabled HWE and thus using the HWE of 4.15 kernel? wiki.ubuntu.com/Kernel/LTSEnablementStack wiki.ubuntu.com/Kernel/RollingLTSEnablementStack
    – guiverc
    Commented Oct 8, 2020 at 21:42
  • The PPA ppa:cappelikan/ppa provides NO support for Xenial; 16.04/Xenial is approaching EOL and only 'main' packages are now supported (3 years of support for flavors and 'universe' packages unless specifically mentioned otherwise). That PPA only supports bionic (18.04) & newer which you should have noticed in your 3rd party security checks prior to adding (PPAs are 3rd party so security checks are on you).
    – guiverc
    Commented Oct 8, 2020 at 21:45
  • @guiverc I have 4.4 wanting to upgrade to at least 4.15. I installed the HWE per the answer below, but that caused two problems: (1) 4.15 doesn't boot (I'm still trying to figure out why) and now I have to revert to 4.4 to use that partition. (2) HWE messed up my multi-boot GRUB, which I'm still working on fixing.
    – DeXoN
    Commented Oct 9, 2020 at 23:39

1 Answer 1

0

Have you tried installing the Ubuntu hardware enablement stack?

sudo apt-get install --install-recommends linux-generic-hwe-16.04 xserver-xorg-hwe-16.04

This will give you a 4.15 kernel and update the xserver. More details to be found here: https://wiki.ubuntu.com/Kernel/LTSEnablementStack

2
  • It turns out the Ubuntu hardware enablement stack not only fails to boot, but also messed up the EFI/GRUB boot configuration.
    – DeXoN
    Commented Oct 8, 2020 at 15:58
  • That is unfortunate. I have used it often and have not experienced problems so far.
    – ernstkl
    Commented Oct 9, 2020 at 12:32

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .