I have been trying to get a RAID5 partition going on a home file server with limited success. Thus far, I've managed to build the array, and I can mount it manually.

However, it creates the array at /dev/md127, whereas I was expecting to see it at /dev/md0.

Also, it doesn't automount, I'm assuming because I have to add the individual disks to /etc/fstab? It certainly doesn't like it when I try to mount /dev/md127. I can mount it using the GUI on the server, but commandline mount via ssh fails, anyway.

It's a software-based RAID array using mdadm.

  • I'm not sure if this matters, but is this a hardware based RAID (i.e., to manage it, you'd have to go into BIOS) or software-based? And yes, automount at boot time would require editing /etc/fstab. – Ray Oct 8 '20 at 5:52
  • it's in software. Sorry - slightly important detail. Edited the post to reflect the change. – Joel Graff Oct 8 '20 at 11:16
  • I see! Until now, I've only dealt with hardware-based RAIDs; I've never seen this kind of problem before. I've added the "mdadm" tag...hopefully someone else can help you! Good luck! – Ray Oct 9 '20 at 8:25

Solved. Reformatted the partition using mkfs.ext4 and it showed up and mounted manually. Added to /etc/fstab and rebooted and automounting worked as it should.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.