5

I upgraded to 12.04 right after it was released, and once it installed, I was eager to try the new features. After fiddling around with most of them, I forgot to try the brand new HUD. I tapped the alt key... and nothing happened. I searched around to see if I disabled it, but I didn't. Also, holding alt still showed the appmenu at the top. Is there a reason that it isn't working on my computer?

  • Please can you look at this Q to see if your HUD key is set correctly - thanks askubuntu.com/questions/122209/… – fossfreedom Apr 29 '12 at 21:41
  • It was. But thanks to you, I decided to change it to something different and then back, and I found out the problem (there was a conflict with the HUD and a compiz plug in) – Stramato Apr 29 '12 at 22:25
  • There is a related bug entry in Launchpad: bugs.launchpad.net/bugs/995040 – uzhoasit Jun 28 '13 at 17:34
3

I figured out that it wasn't working because of conflicts with the compiz scale plugin. Now it works!

| improve this answer | |
3

After an upgrade, from 10.04 to 12.04, the HUD did appear with Alt but whatever I typed there were no results. The solution was to type in a Terminal:

sudo apt-get install indicator-appmenu-tools

Then press Enter. It worked!

| improve this answer | |
  • I did this and now I do see results when I type stuff in HUD, but the results seem to come from random places of other apps (not the currently active app) and the results don't even match what I have actually typed... Very weird, has anybody seen this? – Dmitry Pashkevich Aug 8 '12 at 8:01
  • Restarting the computer solved the problem. I think it's worth mentioning in the answer... Thanks anyway! – Dmitry Pashkevich Aug 8 '12 at 8:33
  • Why isn't this installed by default? – Bart Friederichs Sep 4 '12 at 6:31
1

Could reproduce the problem in a Unity 2D session. When logout and switching to normal Unity session the HUD worked. A source says that HUD is not available in Unity 2D and suggests to add an ppa with enabled Unity 2D.

How do I enable Global Menus and fix HUD (after upgrading to 12.04 from 10.04)? suggests to install indicator-appmenu. I tried this solution and after a relogin (or unity --replace in a terminal) HUD was also working in Unity 2D.

There is an open bug report on this issue: https://bugs.launchpad.net/bugs/995040

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.