1

Have been using Ubuntu since version 12 using the very same hardware and everything always worked ok after update. So now I just updated to 20.04 and have no audio thru HDMI or Analog output, and a couple of programs won´t run anymore, as Libre Office, I-Nex, and others. I can go ok without the programs but I need the Audio working. That gave me a flashback of my old Windows OS...As I always do I searched online for a solution and I found that a lot of people are looking for the same solution. I forced reconfig/reload pulseaudio and alsamixer, no result. So as I was writing this post I tried to do some print screen to include here and I couldn´t save the file anywhere, as it would give me "Error creating file". I am not sure if these 2 problems are related but it kinda seems suspicious. I know a bit of Ubuntu but not enough to figure this out. Anyone have some tips to me??? This site won´t let me embed my print screen pictures so links are below. Thanks a lot.

System Information Audio Device-Intel Audio Device-NVIDIA Settings/Sound Alsamixer

2
  • I've never succeeded in an flawless upgrade. Instead I saved my data (& clean up some files I didn't even knew I had) and set up a fresh clean 20.04.
    – kanehekili
    Oct 7, 2020 at 18:21
  • That is a good tip. I keep my system in one drive and all my files in another one so if I loose the system my files are intact.
    – Taganini
    Oct 7, 2020 at 20:26

1 Answer 1

1

I got it working. It looks like the upgrade somehow corrupted my file system, and after trying some things, my system wouldn´t boot anymore and got me to BusyBox, so I run fsck /dev/sda1 (that was my main disk) and typed Y on the errors.

Also after the system boot up ok I notice that I was able to run all the programs again, so I eent to advanced user settings and found that somehow "Use Audio Devices" was off, so I turned back on.

Advanced User settings

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .