5

While opening PDF in Adobe Acrobat in Ubuntu, the fonts are misrepresented as follows. I tried to fix this by checking the option "Use local fonts" but it did not help.

The document reading via Acrobat:

acrobat

whereas the actual PDF (opened in Document Viewer) looks like this:

document viewer

How to fix this issue?

This is the pastebin link where the pdffonts command output for the document is available. The above document can be downloaded from here: EDEM 2.6Theory Reference Guide.

1
  • I had the same issue - askubuntu.com/a/1287140/803807 did the trick! First it still loaded as your snapshot and a few seconds later it re-displayed them in a normal font.
    – stason
    Oct 29, 2020 at 1:54

1 Answer 1

5

I assume you're using Acrobat Reader 9.x for Linux, which is still available on Adobe's FTP server. Although modern web browsers no longer include the FTP protocol, the server is still active and may be accessed with a dedicated FTP client.

The problem is Arial and Times New Roman are being replaced with the generic font Adobe Sans. Fonts have to be copied directly to the Acrobat font folder because it doesn't use the system fonts.

  • Install Microsoft Core Fonts for the Web.

    sudo apt install ttf-mscorefonts-installer
    

    You may have to reinstall if a previous install was unsuccessful.

    sudo apt reinstall ttf-mscorefonts-installer
    
  • Copy the fonts to the Acrobat font folder.

    sudo cp /usr/share/fonts/truetype/msttcorefonts/* /opt/Adobe/Reader9/Resource/Font/
    

Acrobat PDF Fonts

1
  • 1
    Perfect this worked! Once minor thing, the sudo install did not install anything inside /usr/share/fonts/truetype/msttcorefonts/. However adding --reinstall flag helped: sudo apt-get install --reinstall ttf-mscorefonts-installer
    – SKPS
    Nov 4, 2020 at 1:58

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .