6

I run into the same error over and over when I tried up upgrade to 20.04 LTS.

I'm stuck with this LXD Error, can't redo, uninstall or update my system :-/

Error Message:

==> Installing the LXD snap from the 4.0 track for ubuntu-18.04
error: requested a non-existing branch on 4.0/stable for snap "lxd":
       ubuntu-18.04
dpkg: Fehler beim Bearbeiten des Archivs /var/cache/apt/archives/lxd_1%3a0.9_all.deb (--unpack):
 new lxd package pre-installation script subprocess returned error exit status 1
Fehler traten auf beim Bearbeiten von:
 /var/cache/apt/archives/lxd_1%3a0.9_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Bernhard

2
  • Please provide more information. What error you get when you try to uninstall lxd ?
    – KK Patel
    Oct 6 '20 at 11:23
  • Hello, it's running in a error asking for trying "apt --fix-broken install" and that lead's to the same error as above
    – canterro
    Oct 6 '20 at 11:30
11

Try the below and see if that works.

sudo apt purge lxd lxd-client
sudo do-release upgrade
3
  • Great, thank you that did help me to get rid of that LXD error :-)
    – canterro
    Oct 6 '20 at 12:01
  • No worries, if you could please mark above post as the solution, it would be appreciated :) Oct 6 '20 at 12:13
  • 3
    @quadcoretoaster I think the correct command should be "do-release-upgrade".
    – icasimpan
    Nov 9 '20 at 21:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.