Possible Duplicate:
Wireless doesn't work on a Broadcom BCM4312

I have an hp G62-228Ca laptop with a BCM4313 previously running Ubuntu 11.10. I ran the 12.04 upgrade last night without much thought. Following the upgrade and mandatory reboot, the wireless card no longer shows up in the network manager, the first time I've had any kind of issues with wireless under Ubuntu.

I've done much Googling on the issue but so far I haven't found a permanent solution. Mucking around with some packages though (I've installed five different ones or so), I've managed to devise a workaround that I must run every time I boot the laptop. I have to remove the Broadcom STA driver and reinstall it. Inspiration taken from here: WiFi does not work, Broadcom STA Wireless driver does not work on a BCM4313 After the second modprobe command, the wireless reappears in the network manager and ten seconds after that I'm back on the wifi.

If anyone can provide some advice on how to fix this permanently I will be extremely grateful. I'd rather not roll back to 11.10 or reinstall, but I will if I need to. Just let me know if you need the output from any terminal commands.

Thanks in advance!


Looks like there's a bug filed. You might want to add yourself as affected and subscribe.

Also, this workaround shows how to blacklist the offending module and put the right one in place instead.

| improve this answer | |

The open source bcma driver works fine.

sudo rmmod wl
sudo modprobe bcma

sudo reboot

This did the trick for me.

| improve this answer | |

First, try the STA driver. Connect the Ethernet cable to get to the Internet, and go to System Settings, Additional Hardware and enable the STA driver and reboot.

If that doesn't work then disable the STA driver, reboot, connect the Ethernet cable to get to the Internet, and run this command:

sudo apt-get install firmware-b43-installer
| improve this answer | |
  • Is the kernel patch apparently necessary for this chipset included in Ubuntu 's kernels? Don't fancy going away from stock kernels... – artfulrobot Jul 15 '12 at 19:02

The problem with Broadcom 4313 on Ubuntu 12.04 is due to wireless channel of your router. Set the channel under 12 and the wireless card will connect to the LAN. I've tried every possible alternative solution before doing this. Nothing else is needed, unless the driver suggested by Ubuntu and this setting of the wireless channel. It has worked for me.

| improve this answer | |

Not the answer you're looking for? Browse other questions tagged or ask your own question.