Just installed 12.04 LTS and I experience some problems with my touchpad. Everytime I tap/double tap, the cursor is moving around (not static as should be). For example if I want to close a window, I click on "x" button from touchpad, the cursor is moving and not always hit the "x" button. Touchpad buttons left click, right click are working well, but tap not. Did u guys experience the same problem? Is there something related to sensitivity? How to fix it?

PS: on Ubuntu 11.10 didn't had this issue

It looks like your touchpad still feels too much pressure when your finger is released.

If you are using synclient, you might try to increase the FingerLow value.

here is how I did with my computer:

$ synclient | grep FingerLow
    FingerLow      = 30
$ synclient FingerLow=35

Note that FingerLow cannot be higher than FingerHigh. So change this value as well if needed.

  • 1
    The SamK's answer works for me, it's just a driver configuration issue. To make the configuration permanent I created the file /etc/X11/xorg.conf with this content. The values should be configured experimentally. – Carlos Jun 16 '13 at 19:17
  • Values that work well for me on a System76 Galago UltraPro are: FingerHigh=50, FingerLow=45. – jdthood Apr 29 '14 at 21:08

After digging through the available options to synclient it would seem that

Option "HorizHysteresis" "40"
Option "VertHysteresis" "40"

effectively prevents the pointer from "skipping" when I click. I also enabled two finger scrolling.

My /etc/X11/xorg.conf file:

Section "InputClass"
    Identifier "touchpad"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "FingerLow" "30"
    Option "FingerHigh" "40"
    Option "VertTwoFingerScroll" "1"
    Option "HorizTwoFingerScroll" "1"
    Option "TapAndDragGesture" "0"
    Option "HorizHysteresis" "40"
    Option "VertHysteresis" "40"
    Option "ClickPad" "1"
EndSection
  • Yup that does the trick! Awesome thanks :) – w00t Jun 15 '14 at 17:38

https://help.ubuntu.com/community/SynapticsTouchpad

This helped with my HP ENVY 17, took some tweaking of the numbers and it's pretty good now.

Your Answer

 

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.