After following all the instructions in CUDA Toolkit 11.1 Downloads, the last instruction

sudo apt-get -y install cuda

doesn't work for me.

Terminal shows this message:

The following packages have unmet dependencies:
 cuda : Depends: cuda-11-1 (>= 11.1.0) but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

PS: I have an NVIDIA GTX 1660TI card in my computer.

Any solution please?

  • Does this answer your question? Unable to correct problems, you have held broken packages
    – karel
    Oct 5, 2020 at 16:02
  • Does anything not work after your dpkg -i install, which should have supplied all necessary files? Might have been a cut and paste error on Nvidia's part from their debnetwork install.
    – ubfan1
    Oct 5, 2020 at 16:12
  • same issue with Cuda 11.3 on Ubuntu 20.04
    – rob
    Apr 30, 2021 at 9:01

5 Answers 5


I just ran into this issue and solved it by running the following commands:

sudo apt clean
sudo apt update
sudo apt purge nvidia-* 
sudo apt autoremove
sudo apt install -y cuda

Major thanks to this post on the Nvidia forums.

  • 5
    solved it for same issue for cuda 11.3 on Ubuntu 20.04
    – rob
    Apr 30, 2021 at 9:01
  • 2
    Matt, the post you referenced had apt purge cuda after apt update. Any reason you didn't use that step from the post you referenced? May 11, 2021 at 16:23
  • 1
    @user1045680 Good question and good point. I normally try to do the least destructive thing possible when debugging things. If it fails, I then try again with more destruction! So I think I first ran it without apt purge cuda to see what would happen... it ended up working, and I posted it! Adding apt purge cuda would be a good second attempt if the above list of commands fails. May 12, 2021 at 17:25
  • thanks matt, this solveddd it for me, Ubuntu 20.04 Jul 22, 2022 at 15:13
  • The sudo apt purge nvidia-* syntax doesnt work on zsh terminal. I had to use simple bash. Aug 6, 2022 at 6:51

I think the issue is the CUDA driver version. It looks like the installer tries to install the newest version 455.23.05 and the installation actually fails there.

I've solved it by first downloading the local installer and unselecting the CUDA driver installation, so it just installs the toolkit.

wget https://developer.download.nvidia.com/compute/cuda/11.1.0/local_installers/cuda_11.1.0_455.23.05_linux.run
chmod +x cuda_11.1.0_455.23.05_linux.run 
sudo ./cuda_11.1.0_455.23.05_linux.run 

In the menu unselect the driver installation: enter image description here If not already done, add the nvidia repo as per instructions from the official website before installing the driver:

wget https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/cuda-ubuntu1804.pin
sudo mv cuda-ubuntu1804.pin /etc/apt/preferences.d/cuda-repository-pin-600
sudo apt-key adv --fetch-keys https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/7fa2af80.pub
sudo add-apt-repository "deb https://developer.download.nvidia.com/compute/cuda/repos/ubuntu1804/x86_64/ /"
sudo apt-get update

Install the CUDA driver 450 manually:

sudo apt-get install cuda-drivers-450

Test by running nvcc -V In case nvcc is not found, don't forget to add it to your PATH: PATH=$PATH:/usr/local/cuda/bin

  • 1
    I just added the "PATH=$PATH:/usr/local/cuda/bin" in my path and it works well now ! Thank you ! Oct 30, 2020 at 8:35
  • Worked like a charm and yes you need setting PATH like Taha mentioned.
    – Mian Ahmad
    Feb 19, 2021 at 9:28
  • This really helped. The posts above (and below) talk of purging the machine of Cuda related material. Sadly, that didn't resolve the issue, but this approach did. Oct 18, 2021 at 14:24

You have to uninstall any nvidia driver before running sudo apt install -y cuda
To do so, got to "Software & Updates" -> "Additional drivers" -> Using X.Org X (nouveou)

  • 1
    Actually works.
    – Update
    Dec 11, 2020 at 2:27

As in the previous post, I run this for Ubuntu 20.04 Nvidia Quadro P520:

sudo apt clean 
sudo apt update

sudo apt purge nvidia-*  
sudo apt autoremove

Reboot your PC and run this:

sudo apt install -y cuda
  • The OP asked about 18.04, will your solution work for this version ?
    – kanehekili
    May 8, 2021 at 22:56
  • Seems to be a duplicate solution of my answer... I know you don't have enough reputation to leave comments, but this probably would have been best as a comment "can confirm this works on Ubuntu 20.04 with Nvidia Quadro P520". Glad it worked for you! Jul 26, 2021 at 18:58

What helped me in resolving this issue is that I installed up to dated version of the nvidia driver with command "sudo apt install nvidia-driver-NNN" and then pointed on it to be used from the Software & Updates - Additional Drivers

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .